WordPress.org

Ready to get started?Download WordPress

Forums

Slow Database, Slow WP - Help? (8 posts)

  1. wordpressnoob2009
    Member
    Posted 6 years ago #

    Hi, guys, maybe someone can help me. I'm running the latest WP, and I've noticed that my WP is incredibly slow right now. At first, I blamed the database size being too big (40megs), but after talking to my host, they tell me that's not that big at all, and it could be something with my WP. So that's why I'm here.

    First of all, publishing posts works just fine, but it's the act of publishing itself that is a drag. Whenever I press "Publish", it takes WP ages to present me with the "Post Published" message. Mind you, the post actually publishes to the front page MUCH FASTER (as in a few seconds after I click "Publish"), but it's the back-end system, the WP admin area, where it seems to be doing something like publishing, even though it's already published. If that makes any sense?

    Also, it takes forever to delete a post; likewise to edit it. And I can no longer delete posts in bulk; it will only delete one post at a time, and even that takes ages. We're talking 2-3 minutes each here. Sometimes it just times out and doesn't delete.

    I've been having this problem for a while, but the slow-down periods have gotten immeasurably longer when I upgraded to 2.5.1. It was always slow, but now it's just practically CRAWLING along, so that now I will press "Publish" for new posts, check to see if it's shown up on the front page, and just interrupt the process before the "Post Published" message is displayed, and it all works fine. But I would rather just fix this slow-down in the back-end system if possible.

    Thanks.

  2. wordpressnoob2009
    Member
    Posted 6 years ago #

    nevermind, guys, i figured it out. It was my Google Sitemap Plug-in. As soon as I updated it (just released), the lag time disappeared.

  3. smchugh
    Member
    Posted 6 years ago #

    have been trawling the web and came across this post and wondered if anyone else had seen similar problems. Sounding much the same as the one above, except I don't have the google sitemap plugin to upgrade!

    Either saving or publishing a post takes a couple of minutes, which is pretty hopeless. Deleting posts (or, more than one at a time, as above) actually generates 500 errors, caused I think by timing out (unfortunately my web provider isn't the most technically adept - see if you can guess who!)
    There's another weird thing, the save and publish buttons 'flash' maybe halfway through the process. It might be the autosave thing. (This adds to the complication as it means I have hundreds of drafts that I can't delete, plus as I use custom fields I have that 2.5 bug to contend with too!)

    Anyway, I digress - any bright ideas? Anyone?

  4. meetjustin
    Member
    Posted 5 years ago #

    I am having the same exact problem on my blog and there seems to be no solution out there I can find.

    Can't delete in bulk.
    When I save it takes minutes to complete - if it even does because most of the time I get "Connection Timed Out."
    When I save or edit a post my entire blog will go down for about 1-2 minutes with "Connection Timed Out" and then will come back up.

    Some people are saying it may be wp-cron, but I installed Crontrol and I don't see many cron jobs at all - and nothing that would cause this kind of problem.

  5. kbzero
    Member
    Posted 5 years ago #

    I had very slow updates, deletes, changes, new posts

    and when I deactivated the google sitemaps plugin, things now run smoothly.... and quickly.

    I will just reactivate the plugin when I am finished updating the blog.

    Then I can manually generate a new xml sitemap.

  6. nast0
    Member
    Posted 5 years ago #

    I'll add my experiences to this thread, hoping it helps people.

    I have a WP 2.7 blog with 10,500 posts, 28 cats, 4,500 tags. Editing, deleting, inline updating was incredibly slow. 45+ seconds in some cases, it seemingly locked the DB during those 45 secs, and pushed my server load to 5+, so users were severly impacted.

    Disabling the Google Sitemaps plugin has helped a LOT, not entirely, but I'll take any speed increase I can get. There are other threads about that indicate it may be the number of services you have your blog set to ping about updates. There's maybe a small win in there, but I'm happy.

    Thanks for taking the time to post,
    n

  7. nast0
    Member
    Posted 5 years ago #

    Worthy of note that you don't need to fully disable the Sitemaps plugin, unticking;

    Building mode:
        * Rebuild sitemap if you change the content of your blog

    Will have the same effect. You just need to click the rebuild button every time you post.

    Thanks,
    n

  8. goodenvy
    Member
    Posted 5 years ago #

    I've been thinking that the wp dashboard is a bit faster on wordpress.com versus on my own shared server but it's not that slow.. never 1min or 2 mins to publish a post.. etc.

    I would certainly look into what plugins you last installed or even what theme you last installed before you started experiencing the "crawling" publishing.

    I've got wp 2.7 and about 5-7 plugins on average for each wordpress installation. No complaints or crawling here.

    ~Adrie Silva
    http://www.silvaprints.com

    Hosting ∞ Design ∞ Tutorials

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags