WordPress.org

Ready to get started?Download WordPress

Forums

Slow (6 posts)

  1. Steve
    Member
    Posted 4 years ago #

    The admin backend for 3.0 seems significantly slower than WPMU 2.9.2's backend.

    Has anyone else noticed that or is it just me?

  2. holo-alan
    Member
    Posted 4 years ago #

    seems about the same to me.. sorry

  3. Steve
    Member
    Posted 4 years ago #

    It was the object-cache.php causing problems - but I'm not sure what or why.

  4. eitch
    Member
    Posted 3 years ago #

    I'm also having problems with backend being very slow (2.9.2) compared to frontend usage. I use object-cache with memcache on another server. The CPU usage and memory usage are more than good.

    But in the backend... WordPress is very slow even to begin responding the first bytes to the client... :( Anyone also experienced this?

  5. eitch
    Member
    Posted 3 years ago #

    I just solved the problem, disabling any type of cache on administration directly. After these modifications, backend got really, really fast.

    In /wp-config.php:

    # Cache
    if (stristr($_SERVER["SCRIPT_FILENAME"],'/wp-admin')) {
       define('WP_CACHE', false);
    } else {
       define('WP_CACHE', true);
       global $memcached_servers;
       $memcached_servers = array('default' => array('memcache-server1:11211', 'memcache-server2:11211'));
    }

    (Remember to comment any other WP_CACHE definitions in the file, leaving only this code.)

    And in /wp-settings.php, around line 336 (WPMU Version 2.9.2)

    if ( file_exists(WP_CONTENT_DIR . '/object-cache.php') && (is_admin() == false) ) {
            require_once (WP_CONTENT_DIR . '/object-cache.php');
            $_wp_using_ext_object_cache = true;
    } else {
            require_once (ABSPATH . WPINC . '/cache.php');
            $_wp_using_ext_object_cache = false;
    }

    So if it's in administration, it never loads the object-cache.php that is necessary for memcached caching. Anything else, it executes normally.

  6. eitch
    Member
    Posted 3 years ago #

    Well, after some days testing this approach, it didn't work quite as expected. The database cache was constantly out of sync with the real data, so things like comments count and scheduled posts were not working. I reverted back to the original and began using wp-varnish as a cache mechanism, eliminating memcached totally.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.