WordPress.org

Ready to get started?Download WordPress

Forums

WP SlimStat
[resolved] Slimstat is not working? (20 posts)

  1. grandpajim
    Member
    Posted 1 year ago #

    Slimstat has been working great since last May 21, 2012 when I set up my WordPress web site. Since February 1st, it is recording only a few visits a day.

    On February 1, 2013, I updated my site theme, 2011, which I had not done before. After this, Slimstat started reporting only very limited data. I checked the FatCow usage statistics and people are visiting, but Slimstat is not recording all these visits. Could the theme update have messed up things?

    I checked the threads above and saw one where changing Java Script mode to "No" helped that person. I tried and still no improvement.

    My URL is http://www.unclejoestories.com/

    Any help appreciated. I really like Slimstat.

    Jim

    http://wordpress.org/extend/plugins/wp-slimstat/

  2. camu
    Member
    Plugin Author

    Posted 1 year ago #

    You should make sure that your theme is calling wp_footer() somewhere in footer.php ;) Please check the installation instructions and the FAQs for more information.

    Cheers
    Camu

    PS: a vote for my plugin would be a nice way to say thank you!

  3. grandpajim
    Member
    Posted 1 year ago #

    Wow.

    I am a bit of a neophyte at this web-site stuff. Fascinatingly termed idea, sounds complicated -- before I step out on that limb, a question:

    I remembered I upgraded to Slimstat 2.9.2 on the same day I updated the theme.

    Following one of the other threads, I have set Javascript Mode to No and Track Browser Capabilities to No. This seems to help. Now, I am getting some visits showing on Slimstat, but possibly not as many as I suspect are occuring.

    Were there some other settings that were changed in 2.9.2 that I can change back to?

    If not, is there a way to go back to 2.9.1. It seemed to be working fine.

    Thanks for following up,

    Jim

  4. camu
    Member
    Plugin Author

    Posted 1 year ago #

    Yes, you can go back to a previous version, but that means you will lose all the benefits of the new versions that are going to be released in the next future ;) Solving the issue seems to be the best approach. Ask someone a little more web-savvy to lend you a hand.

    Cheers,
    Camu

    PS: previous versions can be downloaded at

    http://wordpress.org/extend/plugins/wp-slimstat/developers/

  5. grandpajim
    Member
    Posted 1 year ago #

    Setting Javascript Mode and Track Browser Capabilities to No seems to have fixed the problem.

    It seems that the cause, for me, was the 2.9.2 update moving these settings from Yes to No.

    I lost four days of data before I reset these buttons. Is there any way to recover that data in Slimstat?

    Jim

  6. memographer
    Member
    Posted 1 year ago #

    @grandpajim - could you please tell in which file those settings are located? I have the same problem after update to 2.9.2. It is recording just a few visitors a day (down from a few hundred a day). Thanks in advance!
    Re: Memographer.com

  7. grandpajim
    Member
    Posted 1 year ago #

    Memographer,

    Sorry to be so slow.

    Javascript Mode is the second button under General -- I moved to No.

    Track Browser Capabilities is the first button under Advanced -- I moved to No.

    I now seem to be back to normal tracking.

    Hope this helps.

    Grandpa Jim

  8. memographer
    Member
    Posted 1 year ago #

    Thanks, Grandpa Jim! I made the changes a few minutes ago. Will see how day stats changed by tomorrow. Best Regards. Memographer

  9. camu
    Member
    Plugin Author

    Posted 1 year ago #

    Marking topic as resolved.

  10. memographer
    Member
    Posted 1 year ago #

    I waited for a couple of days to see how the stats change.
    The above changes helped to normalize the count of pageviews. However, the Visitors are still "off".

    On Feb 7th I got about 5,000 pageviews - which sounds about right. But these 5,000 pageviews were made by only 50 visitors with average 4 pages per visit. In January (before update) my daily count of visitors was in 200-300 range.

    Grandpa Jim,
    How does the count of visitors work on your site?

    Camu,
    Would you recommend any fixes for the visitors count?

    Thanks all!

  11. memographer
    Member
    Posted 1 year ago #

    Adding to the post above-
    I have just updated to 2.9.3 hoping that a new update will fix the previous one, - now all charts have disappeared.

    Camu, you have made a great plugin. I really appreciate that you let us use it free... But, why do you fix a working plugin?

  12. camu
    Member
    Plugin Author

    Posted 1 year ago #

    Memographer, you're right, I should just stop working on this plugin and do something else ;)

    Jokes aside, please set your Refresh Interval to zero, it's a bug that will be fixed soon.

    Thanks,
    Camu

  13. memographer
    Member
    Posted 1 year ago #

    Thank you. Refresh Interval was always zero. It seems like charts are working, it just takes much longer to populate them.

  14. camu
    Member
    Plugin Author

    Posted 1 year ago #

    Could you try to enable the Asynchronous Views in Settings > SlimStat > Views? That should help.

    Camu

  15. memographer
    Member
    Posted 1 year ago #

    Yes, Asynchronous Views helped. Thank you!

  16. camu
    Member
    Plugin Author

    Posted 1 year ago #

    I'm glad it worked! A vote for my plugin would be a nice way to say thank you!

    Camu

  17. memographer
    Member
    Posted 1 year ago #

    Voted. Thank you :)

  18. grandpajim
    Member
    Posted 1 year ago #

    Mimeographer,

    Visitor count looks about where it has been.

    I just set Asynchronos Views to Yes and Refresh Every to 0.

    Everything seems to be working.

    I have not updated to 2.9.3. Still somewhat concerned about doing this when everything seems to be working.

    Grandpa Jim

  19. camu
    Member
    Plugin Author

    Posted 1 year ago #

    Thank you, Grandpa Jim. Version 2.9.4 will address this and other issues. Unfortunately the introduction of this new 'engine', which is now fully compliant with WordPress' guidelines, was a little bumpier than I had hoped. Sorry for the inconvenience.

    Camu

  20. memographer
    Member
    Posted 1 year ago #

    THANK YOU ALL!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic