WordPress.org

Ready to get started?Download WordPress

Forums

WP Photo Album Plus
[resolved] Slideshow widget links not working right (3 posts)

  1. xardoz
    Member
    Posted 1 year ago #

    Hello,
    I'm trying to set up the slideshow widget so that when users click on a photo, it takes them to a specific URL. I've tried setting Table VI B-5a,,c,d to all possible variations, but there are a couple of issues:
    Clicking on the first image in the slideshow takes you to a lightbox popup of the image.
    Clicking on any image in the slideshow after that takes you directly to the image file, no lightbox.
    If I set VI B-5a,,c,d to NO LINK, clicking on the thumbnail in the widget slideshow does nothing.

    If I set up a slideshow on a normal post, the clicking on the photos to take you to different links works. It just doesn't want to work in the widget.

    You can see them both in action here, on my test site.

    http://wordpress.org/extend/plugins/wp-photo-album-plus/

  2. Jacob N. Breetvelt
    Member
    Plugin Author

    Posted 1 year ago #

    The slideshow widget link is configured in Table VI-A2

    Some 'funny' person has put garbage text in the source of your site before <!DOCTYPE html>:

    <h5>I love using PHP!</h5><!DOCTYPE html>

    There is also not a </body> on the page.
    Did you 'destructify` the theme?

    About lightbox: you can only use the wppa+ embedded lightbox when you want to link the slideshow images to lightbox.
    Set Table IX-A6: Lightbox keyname to: wppa
    Select lightbox in Table VI where you want it. (A2 and/or B5).
    Your page should be properly setup (see above) to make the wppa+ embedded lightbox to work. Also see the Theme requirements on this documentation page.

  3. xardoz
    Member
    Posted 1 year ago #

    I changed the slideshow widget link settings and it's working now - thanks!

    Actually, the "I love php" was me trying to "fix" an outdated and unsupported plugin on that page. That's why it's a test site, so I can break it and then fix it before breaking the real site. ;)

    I didn't change the theme to remove the </body>, that was probably the people who developed the theme for us. I'll dig in and make sure the body tag closes in the footer - thanks for the heads-up on that.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic