WordPress.org

Ready to get started?Download WordPress

Forums

Slideshow
[resolved] slideshow version 2.2.0 just crushed my website (10 posts)

  1. gbcc_ghaffari
    Member
    Posted 1 year ago #

    I use two slideshows, one embedded in a static page and one in the widget side bar.

    I was promted to update the plugin to the newest version, which I did. Unfortunately, it crushed my website, i.e. all the single pics of the slide are shown at once all over the page. Please advise.

    http://wordpress.org/extend/plugins/slideshow-jquery-image-gallery/

  2. Stefan Boonstra
    Member
    Plugin Author

    Posted 1 year ago #

    I might have an idea of what may be causing this. Could I perhaps see your website?

  3. gbcc_ghaffari
    Member
    Posted 1 year ago #

    http://www.gbcc.eu

    I'll activate the plugin at 19:15 (in 10 minutes) for few minutes so that you can have a look at the result. Many thanks in advance.

  4. Stefan Boonstra
    Member
    Plugin Author

    Posted 1 year ago #

    That's great, thanks!

    I'll let you know if I find anything.

  5. Stefan Boonstra
    Member
    Plugin Author

    Posted 1 year ago #

    I see you're using the W3 Total Cache plugin, which helps pages to load faster by saving the page's content every couple of hours.

    This may be the reason the slideshow didn't work after the update, as there's been lots of changes in the script and the stylesheets.

    Emptying the cache of the W3 Total Cache plugin may solve the problem.

  6. gbcc_ghaffari
    Member
    Posted 1 year ago #

    emptying the cache didn't help. just deactivated W3 total cache in order to solve this first which is more important to me.

    with this, the issue with the single pics showing up was solved. figured out that you've a new function which caused the 2nd remaining problem: proportional relationship default 4:1

    changed it and this problem is fixed too.

    a last issue remains: the slide doesn't float in the text any longer. Any hint?

  7. gbcc_ghaffari
    Member
    Posted 1 year ago #

    re floating, if the code below is the place to look at, all seems to be alright, innit? but it doesn't float!

    .slideshow_container {
    float: left;
    margin-right: 60px;
    margin-bottom: 30px;
    }

  8. Stefan Boonstra
    Member
    Plugin Author

    Posted 1 year ago #

    In the new version, a lot of HTML has changed. To keep the slideshows from being un-styled after the update, all slideshows were reset to the default 'Light' stylesheet.

    The CSS code you showed me should still be in your customized stylesheet, so you'll need to create a new custom stylesheet and paste the CSS code in there. Then you, of course, have to assign the newly customized stylesheet to the slideshow.

  9. gbcc_ghaffari
    Member
    Posted 1 year ago #

    Stefan, did as advised. If you don't mind have a look please at the result: float works but margin-right apparently not! Any hint on this? Cheers,

  10. Stefan Boonstra
    Member
    Plugin Author

    Posted 1 year ago #

    You did everything right, the slideshow's functional stylesheet just overrules these margin rules because it's included at a later point in the page.

    To solve the problem right now, you could make the CSS values look like this:

    .slideshow_container {
    float: left;
    margin-right: 60px !important;
    margin-bottom: 30px !important;
    }

    This lets the browser now that these values should not be overruled.

    Tonight I'm releasing version 2.2.1 though, which will fix this behaviour.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.