WordPress.org

Ready to get started?Download WordPress

Forums

Slideshow
[resolved] Slideshow "Static" - No slide (2.1.21) (8 posts)

  1. Zencowboy
    Member
    Posted 1 year ago #

    Slideshow 'static' and only shows first slide and no sliding or manually way to make to slide. I see that you have been very helpful to others and I tried to figure it out on my own but to no avail..sorry.

    I really like your layout and options! Here is the page I put it in sidebar And body to see if that would help you help me figure out the issue.
    http://dazzlingphotobooth.com/faq/

    2.1.21 my plugin pages says and 3.5 WP on pro theme Jad.

    My pics are 194x579px (most of them) that are Photo Strips for a Photo Booth co.

    Thank you so much for your time and help!!

    http://wordpress.org/extend/plugins/slideshow-jquery-image-gallery/

  2. Stefan Boonstra
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks for including your website.

    Your site throws a JavaScript error that says the following: 'Uncaught TypeError: Cannot call method 'substr' of undefined'. This error is caused by your theme's 'custom.js' JavaScript file on line 379. This error stops all JavaScript execution and the slideshow therefore won't work.

    Adding the following in between lines 378 and 379 (before the error causing 'if' statement) should solve the problem:

    if(src == undefined) return;

    Unless there are any further errors in the JavaScript file though. I would then advise you to contact the guys who built the theme.

  3. daves1997
    Member
    Posted 1 year ago #

    Will this plugin help me with the following issue?

    I need to do a wordwrap on my slideshow.

    <script charset="UTF-8" type="text/javascript" src="http://listing.bestfortmyersrealestate.com/idx/customslideshowjs.php?widgetid=30954"></script>

    Thanks
    Dave

  4. Zencowboy
    Member
    Posted 1 year ago #

    Thanks for the response Stefan! I put that code on line 379 but did not work...I know it is probably a simple error on my part so I copied the custom.js lines to show you what I may have done wrong:

    /*ef-view*/
    $('a:not(.ef-view) > img').each(function(){
    var a = $(this).parent();
    var src = $(this).attr('src');
    var url = $(a).attr('href');
    if(src == undefined) return;
    if (url.substr(-3, 3) == src.substr(-3, 3)) new View($(a));
    });
    $('div.gallery').each(function(){
    var src = $('a:first > img', this).attr('src');
    var url = $('a:first', this).attr('href');
    if (url.substr(-3, 3) == src.substr(-3, 3)) new View($('a', this));
    });

    Your code (if(src == undefined) return;) is on line 379 now due to pushing one line
    down when inserted.

    Should I move it elsewhere?

    Thanks so much and totally want to use this slider!!

  5. Stefan Boonstra
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Dave,

    I'm sorry, I have no idea what you mean. You may want to make a new thread for your issue, the thread you posted to doesn't seem to relate to your post's subject.

    Best regards,
    Stefan

  6. Stefan Boonstra
    Member
    Plugin Author

    Posted 1 year ago #

    Hi ZenCowboy,

    You've done everything correctly, I overlooked the 'url' variable. The statement you need to add actually looks like this:

    if(url == undefined || src == undefined) return;

    Best regards,
    Stefan

  7. Zencowboy
    Member
    Posted 1 year ago #

    You da man! It works! Thanks for taking the time! Wowslider is not working and folks should know about yours!

  8. Stefan Boonstra
    Member
    Plugin Author

    Posted 1 year ago #

    That's great, I'm glad to hear it. You're very welcome!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.