WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Slideshow Pro (16 posts)

  1. rwe121
    Member
    Posted 8 years ago #

    I have had this Slideshow Pro for months now and cannot figure out how to get it put on my Worpress based blog. I have it uploaded to my server and it works fine, but when I add the code to my WYSIWYG editor or HTML editor, I just end up getting a bunch of visisble code. I don't understand where I am going wrong. If someone could assist I'd appreciate it.

    Here is the slideshow I want to add to my site:
    http://www.frecsandspecs.com/Slideshow.html

    Here is where I want it: http://www.frecsandspecs.com/?page_id=5

    I'm going to put the code in as I read I am suppose to so perhaps someone might see where I am going wrong.

    Any advice would be appreciated.

    Thanks!

    SSS AKA. Self proclaimed Slideshow Pro retard

  2. rwe121
    Member
    Posted 8 years ago #

    Well, I put the code in that I thought was suppose to get it up and running. I fixed one of the tags that made the code visible, but it isn't showing anything.

    No slideshow.

    Please someone help me get this thing going on my site instead of only on my server.

    Thanks ahead of time folks!

  3. Ryan Fitzer
    Member
    Posted 8 years ago #

    I worked very hard to get the earlier free version of slideshow (before it went pro) into a post and after hours and hours I figured out that all files that have paths in them that point to separate files have to be absolute. This means you have to get into the actionscript and alter that as well as any xml files. Here's where I got the original to work. This one is in a post.

    http://www.ryanfitzer.com/dev/wp/

    It's a bare bones theme in development by the way. No frills so far.

  4. rwe121
    Member
    Posted 8 years ago #

    Hmm thanks. I read about the absolute and relative paths. I thought I had made mine absolute. Perhaps I need to go back and read some more to see where I went wrong. The thing with this kind of stuff is it is sooooo time consuming. I spent all day yesteday trying to figure it out even trying to e-mail someone who wrote on here a year ago with the same issue. He hasn't gotten back to me as of yet. *Sigh*

    Thanks! I'm going to look back at my paths,etc. If I get it going I'll let you all know. Otherwise....consider me still clueless.

    SSS

  5. Ryan Fitzer
    Member
    Posted 8 years ago #

    I tried everthing I could find on the forums but none of it really worked for slideshow. I'm not sure the file structure of slideshow pro, but I'm assuming it was built upon the original free version. If so, I put in the absolute paths in images.xml as well as the original flash file (.fla). Then I did the same for the path to it from a post. It would definitely take some time to search (and you would need Flash), but it sure would be nice.

  6. geoffe
    Member
    Posted 8 years ago #

    rwe121, your code on your wordpress page is:
    <p><object width="550" height="400" align="middle" classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://fpdownload.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=8,0,0,0" id="Slideshow"></p>

    <param name="allowScriptAccess" value="sameDomain" />
    <param name="movie" value="Slideshow.swf" />
    <param name="quality" value="high" />
    <param name="bgcolor" value="#ffffff" /></object>


    If it was
    <object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://fpdownload.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=8,0,0,0" width="550" height="400" id="Slideshow" align="middle">
    <param name="allowScriptAccess" value="sameDomain" />
    <param name="movie" value="Slideshow.swf" /><param name="quality" value="high" /><param name="bgcolor" value="#ffffff" /><embed src="Slideshow.swf" quality="high" bgcolor="#ffffff" width="550" height="400" name="Slideshow" align="middle" allowScriptAccess="sameDomain" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer" />
    </object>
    instead, like on your Slideshow.html example page, it would work.

    Indeed, you need to be careful when using relative urls, particularly where WP will put your post in "yourdomain.xxx/archives/" so if your SSP file is going to be in the site root, you should specify things like <param name="movie" value="/Slideshow.swf" /> and <embed src="/Slideshow.swf" ..., which precedes the filename with /, so that the file is not relative to the current directory but to the site root.

    And it is important to specify the filename for both the param name value and the embed src value, sadly.

  7. Ryan Fitzer
    Member
    Posted 8 years ago #

    Make sure you turn off the rich text editor before you cut and paste this code in there or else it will strip out the <embed> element. I'm still not sure this is the fix but definitely let us know if that was the only problem.

  8. rwe121
    Member
    Posted 8 years ago #

    Okay, I'm going to look into all of these things. Thanks for replying you guys! I really appreciate it. I DO have Flash and so I should be able to change the appropriate paths etc.

    I may not get this up tonight, but I'll def let you know the outcome. Especially since I think it is important to document so others who run across a similar issue may have something to refer to when troubleshooting.

    Wish me luck!

  9. rwe121
    Member
    Posted 8 years ago #

    Okay, I got it working FINALLY!

    It really only took me two minutes as I just now got back around to messing with the slideshow. I realize now what the problem was. Thank you for making me realize I had the Rich Text Editor on. After I turned it off and cut and paste the code it worked.

    I'm so happy it's working :) YAY!! Thank you geoffe and Ryanfitzer!!

  10. Ryan Fitzer
    Member
    Posted 8 years ago #

    Great, good to know that it wasn't the absolute path issue (I'm still confused why though) because that is a great slide show app.

  11. rwe121
    Member
    Posted 8 years ago #

    I'm sure I'm still not doing something right. In time it will come together I suppose.

    Now I have an issue where I updated my Flickr pics and it is not updating in my slideshow. Perhaps it has something to do with that absolute path thing? Or it has something to do with this.....my XML file
    http://www.frecsandspecs.com/sarahs_slideshow.xml

    It says I have a parsing error. It's been like this for a while and it has still been working, so I'm confused. It must have to do with the path or something ehh?

    I added a picture just the other day and it is up there, so it WAS working yesterday. In terms of updating.

    Perhaps there is a lag between updating and the feed? Any thoughts guys?

    Sarah

  12. rwe121
    Member
    Posted 8 years ago #

    Well this is what it says on my xml page:

    XML Parsing Error: not well-formed
    Location: http://www.frecsandspecs.com/sarahs_slideshow.xml
    Line Number 7, Column 97: <outline xmlUrl="http://www.flickr.com/services/feeds/photos_public.gne?id=99729546@N00&format=rss_200" />
    --------------------------------------------------------------------------------------------------

  13. rwe121
    Member
    Posted 8 years ago #

    Okay, well....it's probably time I get to bed since I'm writing before thinking. I cleared my cache folks and it updated.

    Feeling awfully ridiculous over here. I'm still confused about that parsing error though.

    Ahh well. I'll get it together eventually. Thanks for everything (again!) night!

  14. Layoknee
    Member
    Posted 8 years ago #

    Ok...I'm dealing with the same issue: how to get my SSP working in my wordpress blog...I tried and read a lot, but I'm getting confused now so I hope you can help me...

    okay at http://www.lexleonie.nl/slideshow.html everything working fine, I would like to show the slideshow here:

    http://www.lexleonie.nl/fotos/

    but nothing but an empty space...

    the images.xml + slideshow.swf are both in my root folder, and this is how I try to put in in the page (using kimili's plugin):
    [kml_flashembed movie="http://www.lexleonie.nl/slideshow.swf" height="270" width="400" fvars="xmlDataPath = http://www.lexleonie.nl/images.xml" /]

    I turned off the rich text editor and checked my paths over and over again....but I just can't find the problem...probably missed something small or it's still a path issue....someone ideas??

  15. Layoknee
    Member
    Posted 8 years ago #

    I don't know what happened here (I thought I refreshed the page?!): but it works, so no help needed anymore...

  16. ronDomingue
    Member
    Posted 7 years ago #

    I got it to work fine in mine with the SPP Director as the admin.

    http://www.rondomingue.com

    My problem is abit more involved. I want to maintain peramlinks so I need to set the object with a relative path I guess or write a conditional statement for the slideshow to not appear on subsequent pages.

    // Ron

Topic Closed

This topic has been closed to new replies.

About this Topic