WordPress.org

Ready to get started?Download WordPress

Forums

Slideshow
[resolved] Slideshow navigation linking to photo URL (6 posts)

  1. greenireland
    Member
    Posted 10 months ago #

    I've added 4 slideshows to my site. Two are working fine. But the navigation isn't working on the other two. The navigation arrows and pagination buttons all direct to the URL of one of the photos in the slideshow.

    I can see that this link will happen in the bottom left as I hover over the arrows or pagination dots.

    If I hover over the pagination dots on the two working slideshows the URL doesn't appear in the lower left, and they work fine.

    I can't for the life of me work out what's different between the slideshows. I've compared them side by side and they appear identical. I've also gone back about six months in the support forum but can't see anything similar.

    Thanks.

    http://wordpress.org/plugins/slideshow-jquery-image-gallery/

  2. Stefan Boonstra
    Member
    Plugin Author

    Posted 10 months ago #

    It sounds like the z-index of the anchor elements is higher than the z-index of the buttons.

    Could I perhaps see your website please?

  3. greenireland
    Member
    Posted 10 months ago #

    Thanks for your prompt reply.

    I have no idea what that means about z-index.

    This is a post that isn't working.

  4. Stefan Boonstra
    Member
    Plugin Author

    Posted 10 months ago #

    I'm sorry, a "z-index" is a value that can help style a page. In your case it doesn't apply to the problem you're having.

    Your slideshow is wrapped in an '<a>' (link) element. This means that everything in your slideshow becomes a link. If you take it out of the link element, you should be able to use the buttons again.

  5. greenireland
    Member
    Posted 10 months ago #

    D'oh!! Sorry about that. I had the old photos already there, and just clicked 'insert slideshow'. I should have checked the HTML. Sorry about that and thanks for your help.

  6. Stefan Boonstra
    Member
    Plugin Author

    Posted 10 months ago #

    No problem, you're welcome!

Reply

You must log in to post.

About this Plugin

About this Topic