WordPress.org

Ready to get started?Download WordPress

Forums

Slideshow Satellite
[resolved] Slideshow does not load on Homepage, works in inner Pages (19 posts)

  1. dfa_admin
    Member
    Posted 1 year ago #

    Hi I have the slideshow in my Header file. It doesn't load on the Homepage (Main Index Template page) but it loads on all the inner pages. (Page template)

    The annoying thing is that it WAS working. And then when I logged in the other day it wasn't. I know it can work, because it was. And then it suddenly stopped working on the homepage (just getting continuous loading icon) but when I go to a inner page it works perfectly. I haven't installed any plugins or done anything to it.

    I have plugin version 2.0.2

    Help!

    http://wordpress.org/extend/plugins/slideshow-satellite/

  2. cpres
    Member
    Plugin Author

    Posted 1 year ago #

    Are you seeing any javascript errors? If you're seeing continous loading it's usually a conflict, or some prior javascript issue that has a jquery issue that then causes my plugin to error out.

  3. dfa_admin
    Member
    Posted 1 year ago #

    I'm not sure....why would it work on the inner pages but not the homepage? The homepage has the same type of content...just text and images. I don't think I have any other type of javascript running beside the one for the plugin.

    I have the site under construction right now. But here are the view source links..let me know if you can take a look at these and see if there's a problem. I appreciate your quick response.

    Homepage:
    view-source:http://anytimelabtesting.com/

    Inner page:
    view-source:http://anytimelabtesting.com/wellness/

  4. cpres
    Member
    Plugin Author

    Posted 1 year ago #

    I think your Maintenance mode must be on, all I see is:

    <style type="text/css">
    	body { background: url('http://anytimelabtesting.com/images/temp.jpg') no-repeat;
    	background-position: top center;
    		margin: 0 auto;
    		padding: 0;
    		width: 1060px;
    		min-height: 1238px;
    	}
    </style>
  5. dfa_admin
    Member
    Posted 1 year ago #

    Ok I just took maintenance mode off...I'll need to put it back on quickly though since Client needs it to be private...let me know when I can turn it back on, thanks!

  6. cpres
    Member
    Plugin Author

    Posted 1 year ago #

    Ah, the old no css and js being loaded for the satellite, please check out the manual and look for "Troubleshooting"

    http://bit.ly/stlmanual

    You need to either do [satellite display=off] or turn off Shortcode Requirement, as you're most likely doing the embed through PHP rather than wordpress pages.

  7. dfa_admin
    Member
    Posted 1 year ago #

    Okay! Yes, I'm using php but I'm using a php function that "echos" the shortcode..is there another way to embed in PHP?

  8. cpres
    Member
    Plugin Author

    Posted 1 year ago #

    No, that's the best way. You just have to workaround that with either/or of those solutions

  9. dfa_admin
    Member
    Posted 1 year ago #

    Shortcode Requirement was already turned off...where should I put [satellite display=off] ?

  10. dfa_admin
    Member
    Posted 1 year ago #

    Unfortunately, the problem still persists. Neither of these solutions work. The slideshow works on the pages. It just doesn't work on the homepage. I keep trying to see if there's anything wrong with my Main Index Template and I can't figure it out. This is very discouraging seeing as it was working and now it suddenly does not. I even put the short code in a page and then echoed that page id in my template and that wouldn't load either! I have a feeling it's something to do with the index. Just don't know what!
    I deactivated my other plugins and that didn't help. I'm at a loss for a solution and I would really like to use this plugin...unless you can refer me to another plugin with caption overlays.

  11. dfa_admin
    Member
    Posted 1 year ago #

    I figured something out....on my homepage it loads this in the footer, but on my inner pages, it loads it in the header...is this why it's not working on my homepage? Because it's automatically being placed in the footer and not the head tags like on the inner pages? I wouldn't consider this thread resolved.

    <link rel='stylesheet' id='slideshow-satellite_styleStatic-css'  href='//anytimelabtesting.com/wp-content/plugins/slideshow-satellite/css/orbit-1.3.1.css?v=2.0.2&ver=3.5.1' media='all' />
    <link rel='stylesheet' id='slideshow-satellite_style-css'  href='//anytimelabtesting.com/wp-content/plugins/slideshow-satellite/css/orbit-css.php?v=2.0.2&pID&navpush=0&nav_opacity=0&width=630&height=358&border=0px+solid+%23CCCCCC&background&infotitle=2&infobackground=%23011b44&infocolor=%23FFFFFF&playshow=N&infomin=Y&thumbheight=75&thumbspacing=5&thumbopacity=70&thumbactive=%23FFFFFF&thumbarea=275&thumbareamargin=30&thumbmargin=2&align=none&ver=3.5.1' media='all' />
  12. cpres
    Member
    Plugin Author

    Posted 1 year ago #

    You know, I think you're right. If that is indeed still happening I'd try and figure out how to change that. So many themes have some strange custom code that can mess with plugins

  13. dfa_admin
    Member
    Posted 1 year ago #

    Thanks for your reply. Yes I figured it out. It was my theme. I switched to a different blank template theme and everything works perfectly. I'm assuming there was a strange code maybe in the functions.php or somewhere. Thanks for your help!

  14. kndesign
    Member
    Posted 3 months ago #

    hi, i hope someone help me to solve this problem.
    i put a shortcode into the page home.php page but it seems like doesnt link the style of carrousel.
    this is the code
    <?php echo do_shortcode('[satellite gallery=1 auto=on thumbs=on]'); ?>

    i dont know what happens, any idea?
    thanks a lot!

  15. kndesign
    Member
    Posted 3 months ago #

  16. cpres
    Member
    Plugin Author

    Posted 3 months ago #

    Looks like you're dealing with the same issue as above. Is there a WordPress page that's being rendered here as well? that's when you can add the [satellite display=off]

    Otherwise you'd have to go to Advanced Settings and choose "Shortcode Requirement: Off"

  17. kndesign
    Member
    Posted 3 months ago #

    like this? [satellite display=off gallery=1 auto=on thumbs=on]
    but then it doesnt show at all :(

    in this page its look great http://fdlarquitectos.tublogya.com.ar/obra/
    but i need on the home

  18. kndesign
    Member
    Posted 3 months ago #

    yess :D i solve it!!
    with Shortcode Requirement: Off
    many thaks!!

  19. cpres
    Member
    Plugin Author

    Posted 3 months ago #

    haha there you go :)

    PS - if you are enjoying the slideshow please feel welcome to help the ratings!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic