WordPress.org

Ready to get started?Download WordPress

Forums

WOW Slider
[resolved] Slider working in CSS only version (6 posts)

  1. antonioayala
    Member
    Posted 5 months ago #

    I am trying to install this slide on our webpage, but it is functioning in CSS only version with no transitions. I emailed support and gave them the URL but the only thing I got back in an email was how to install wow slider to WP, steps which we already did and then did again. They also said there was no jquery.js reference in the page, but when I look at the source code, there is a reference to jquery.js in the header. So I thought maybe I will get a better response through the forum.

    here is the URL: http://www.shardfinancial.com/our-mission-test/

    https://wordpress.org/plugins/wowslider/

  2. WOWSlider.com
    Member
    Plugin Author

    Posted 4 months ago #

    I have just checked your page:
    http://www.shardfinancial.com/our-mission-test/

    The reason of problem is jQuery conflict. WOWSlider uses a standard jQuery that Wordress provides:
    http://www.shardfinancial.com/wp-includes/js/jquery/jquery.js?ver=1.10.2
    It would be great if developers of all plugins and themes use this mechanism. The usage of a built-in jQuery allows to:
    * keep off jQuery conflict;
    * update jQuery file automatically one time;
    * you use only one file for all plugins and theme. So, only one file should be loaded, it allows to increase loading speed.
    But the developer of your theme doesn't use this correct method: he added his own jQuery file. In addition, it's a very old version of jQuery 1.3.2 - was released at February 20, 2009! So, there is a strong probability that a conflict with plugins that use a newer version of jquery will appear.
    Also, the developer of your theme made impossible to simply remove this old jquery file: error message in popup window appears.
    So, to make WOWSlider work and disable error message you should:
    1) Remove the old jQuery file that is added by your theme. I suppose, that it's added in header.php file. You should find and remove the following line:
    <script type="text/javascript" src="http://www.shardfinancial.com/wp-content/themes/shardfinancial/js/jquery.min.js" ></script>
    2) Open the following file:
    http://www.shardfinancial.com/wp-content/themes/shardfinancial/js/myscript.js
    and add the following code:
    window.$ = jQuery;
    in the first line.

  3. antonioayala
    Member
    Posted 4 months ago #

    Perfect, worked like a charm!

    Thank you for the quick response and the actual solution to the problem. Using the email method to support was really starting to frustrate me.

    Great plugin, exactly what we wanted

  4. antonioayala
    Member
    Posted 4 months ago #

    Problem, the solution worked for Chrome, but for Firefox and IE, the Javascript warning box still showed up. Any ideas?

  5. WOWSlider.com
    Member
    Plugin Author

    Posted 4 months ago #

    I checked this solution in the five browsers: Firefox, Google Chrome, Internet Explorer, Opera and Safari. WOWSlider works and the Javascript warning box doesn't showed up in all these browsers.
    I checked your page again but the solution isn't applied.
    Please try to clear browser cache. If problem will persist, please make the changes described in the previous post and we'll check your page again.

  6. antonioayala
    Member
    Posted 4 months ago #

    Sorry I have been working on two other projects and haven't had a chance to get back to this one. I have re-done the steps and now it is working across all browsers. The only thing that has changed is that I updated their WP to the latest version, they were still using an OLDER version. This may have something to do with it, or I just typed something wrong last time. Again, thank you for your quick and thorough response, great support.

Reply

You must log in to post.

About this Plugin

About this Topic