WordPress.org

Ready to get started?Download WordPress

Forums

Slider Not Working...Please Help ASAP! (1 post)

  1. shanewhite42096
    Member
    Posted 2 years ago #

    Downloaded a theme and can not get my slider to work. I have 4 slides published, but only one shows.

    This is the Slider.php code...please help me ASAP. Thanks!

    <?php
    
    $slide_settings = get_option('ct_slide_settings');
    $orderby = $slide_settings['orderby'];
    $order = $slide_settings['order'];
    $tags = $slide_settings['active_slide_tags'];
    $num = $slide_settings['slide_limit'];
    
    if(empty($orderby)): $orderby = 'date'; endif;
    if(empty($order)): $order = 'DESC'; endif;
    
    global $post;
    
    if($orderby == 'views'):
    	$args=array(
    		'post_type' => 'slide',
    		'post_status' => 'publish',
    		'posts_per_page' => $num,
    		'meta_key' => 'Views',
    		'orderby' => 'meta_value_num',
    		'order' => $order,
    		'slide_tag' => $tags,
    	);
    else:
    	$args=array(
    		'post_type' => 'slide',
    		'post_status' => 'publish',
    		'posts_per_page' => $num,
    		'orderby' => $orderby,
    		'order' => $order,
    		'slide_tag' => $tags,
    	);
    endif;
    
    $query = null;
    $query = new WP_Query($args);
    
    ?>
    		<div id="ribbon" class="home">
    			<div class="container_12">
    				<div class="grid_12 alpha">
    					<div class="slide_frame<?php if($query->have_posts()): else: echo ' empty'; endif; ?>">
    						<div id="slider">
    							<div class="slide_holder">
    								<div class="mask">
    									<ul>
    <?php
    
    if($query->have_posts()): while($query->have_posts()) : $query->the_post();
    
    $sl_tagline = get_post_meta($post->ID, '_ct_sl_tagline', true);
    $sl_linkurl = get_post_meta($post->ID, '_ct_sl_linkurl', true);
    
    $img_attr = array(
    	'alt'	=> trim(strip_tags($post->post_title)),
    	'title'	=> '',
    );
    
    ?>
    										<li>
    											<div class="slide">
    <?php if($sl_linkurl): ?><a href="<?php echo $sl_linkurl; ?>"><?php endif; ?>
    												<?php echo get_the_post_thumbnail($post->ID, 'slide', $img_attr); ?>
    <?php if($sl_linkurl): ?></a><?php endif; ?>
    												<div class="slide_content_holder">
    													<div class="slide_content">
    <?php if($sl_linkurl): ?><a href="<?php echo $sl_linkurl; ?>"><?php endif; ?>
    														<h2 class="title"><span><?php the_title(); ?></span></h2>
    <?php if($sl_linkurl): ?></a><?php endif; ?>
    <?php if($sl_tagline): ?>
    <?php if($sl_linkurl): ?><a href="<?php echo $sl_linkurl; ?>"><?php endif; ?>
    														<h3 class="subtitle"><span><?php echo $sl_tagline; ?></span></h3>
    <?php if($sl_linkurl): ?></a><?php endif; ?>
    <?php endif; ?>
    													</div>
    												</div>
    											</div>
    										</li>
    <?php endwhile; endif; wp_reset_query(); ?>
    									</ul>
    								</div>
    							</div>
    							<div class="pag_box">
    								<div class="pag_frame">
    
    								</div>
    							</div>
    						</div>
    					</div>
    				</div>
    			</div>
    		</div>

    This is the Slider Code in Style.css

    /* Homepage Slider */
    .slide_frame {
    	background:url(images/slide_frame_bg.png) no-repeat top left;
    	height:364px;
    	margin:0 auto;
    	margin-left:-10px;
    	overflow:visible;
    	padding:16px 0 0 18px;
    	width:960px;
    }
    .slide_frame.empty {
    	background:url(images/slide_frame_bg_empty.png) no-repeat top left;
    }
    #slider {
    	clear:both;
    	height:365px;
    	overflow:hidden;
    	position:relative;
    	width:924px;
    }
    #slider .mask {
    	overflow:hidden;
    	position:relative;
    	width:924px;
    }
    .mask ul {
    	height:365px;
    	list-style:none;
    	margin:0;
    	overflow:hidden;
    	padding:0;
    	position:relative;
    	width:99999px;
    }
    .mask ul li {
    	float:left;
    	margin-left:0;
    	width:924px;
    }
    .mask .slide {
    	background:#fff;
    	position:relative;
    	width:924px;
    }
    .mask ul img {
    	vertical-align:top;
    }
    .mask .slide_content_holder {
    	position:absolute;
    	right:0;
    	top:220px;
    	width:924px;
    }
    .mask .slide_content {
    	color:#fff;
    	text-align:right;
    }
    .mask .slide_content h2.title {
    	color:#fff;
    	font-size:32px;
    	line-height:32px;
    	margin-bottom:0;
    	padding-bottom:15px;
    	text-shadow:none;
    }
    .mask .slide_content h3.subtitle {
    	color:#629fa6;
    	font-size:14px;
    	margin-bottom:0;
    	text-shadow:none;
    }
    .mask .slide_content span {
    	background:#000;
    	background:url(images/slide_content_bg.png);
    	background:rgba(0,0,0,0.75);
    	padding:5px 10px;
    }
    .pag_box {
    	bottom:20px;
    	float:right;
    	left:50%;
    	position:absolute;
    }
    .pag_frame {
    	left:-50%;
    	position:relative;
    }
    .pag_box ul {
    	background:#fff;
    	float:left;
    	list-style:none;
    	margin:0;
    	padding:7px 8px 5px;
    }
    .pag_box ul li {
    	display:inline;
    	float:left;
    	margin:0 5px;
    }
    .pag_box ul a {
    	background:#fff;
    	border-radius:17px;
    	-webkit-border-radius:17px;
    	-moz-border-radius:17px;
    	box-shadow:inset 1px 1px 3px #828282;
    	-webkit-box-shadow:inset 1px 1px 3px #828282;
    	-moz-box-shadow:inset 1px 1px 3px #828282;
    	display:block;
    	height:17px;
    	overflow:hidden;
    	text-indent:-9999px;
    	width:17px;
    }
    .pag_box ul a:hover, .pag_box ul .selected a {
    	background:#99b5b9;
    	background-image:-webkit-gradient(linear, left top, left bottom, from(rgba(177,198,201,1)), to(rgba(126,163,168,1))) !important;
    	background-image:-moz-linear-gradient(rgba(177,198,201,1) 100%, rgba(126,163,168,1) 100%) !important;
    	box-shadow:none;
    	-webkit-box-shadow:none;
    	-moz-box-shadow:none;
    }

    I really need this resolve asap!

    Thanks in advanced!

    btw, website is http://feastervillechurch.org/wordpress/
    my logo got cut off also, any one know how to fix that?

    [ Please do not bump, it's not permitted here. ]

Topic Closed

This topic has been closed to new replies.

About this Topic

  • RSS feed for this topic
  • Started 2 years ago by shanewhite42096
  • This topic is not resolved
  • WordPress version: 3.4.1