WordPress.org

Ready to get started?Download WordPress

Forums

Meta Slider
[resolved] Slider Hovers Over Site Top Bar After First Transition (9 posts)

  1. square_eyes
    Member
    Posted 1 year ago #

    Odd problem here.

    My site has a floating top bar, when scrolling, the slider sits above the top bar instead of moving under it. It happens after the first transition and from then on.

    It looks pretty unprofessional.

    Any ideas?

    Site...

    http://www.budgiecollective.com

    http://wordpress.org/extend/plugins/ml-slider/

  2. Matcha Labs
    Member
    Plugin Author

    Posted 1 year ago #

    Hi, yes, quite an easy fix,

    Open your style.css file.

    Find this line:

    .top-bar {position:fixed; top:0; left:0; z-index: 2; background:#181818; font-size: 17px; width:100%; color:#fff; padding: 14px 0; -webkit-box-shadow: 0 3px 5px #999; -moz-box-shadow: 0 3px 5px #999; box-shadow: 0 3px 5px #999;}

    Change the z-index value to 9999

    Regards,
    Tom

  3. square_eyes
    Member
    Posted 1 year ago #

    Great! Thankyou so much.

    Top plugin.

    (Feature request: remove, resize or colour margin)

  4. Matcha Labs
    Member
    Plugin Author

    Posted 1 year ago #

    Hi, thanks.

    Request noted! A theme editor is on the backlog, just concentrating on getting 2.0 stable first :)

    If you like it and have a few moments spare please consider leaving a review.

    Regards,
    Tom.

  5. square_eyes
    Member
    Posted 1 year ago #

    Done

  6. Matcha Labs
    Member
    Plugin Author

    Posted 1 year ago #

    awesome, thanks!

  7. square_eyes
    Member
    Posted 10 months ago #

    This has come up again, except this time my drop down menu 'Schedule' drops down underneath the slider. Changing its z-index does nothing.

  8. Matcha Labs
    Member
    Plugin Author

    Posted 10 months ago #

    Hi Square_eyes,

    The Flex Slider 2.2 update changed how the fade effect works.

    You'll need to add this to your stylesheet:

    .metaslider {
    z-index: 0;
    }

    Regards,
    Tom

  9. square_eyes
    Member
    Posted 10 months ago #

    Thanks that worked.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic