WordPress.org

Ready to get started?Download WordPress

Forums

Customizr
[resolved] Slider buttons not working (5 posts)

  1. Seahawksean
    Member
    Posted 8 months ago #

    I have added buttons to some of my slider images to link to secondary pages. I added the button's text and selected a page to link them to. However, when I hover over them the cursor does not turn to a pointer (pointing finger) as it should over a link and when I click on it nothing happens.

    When inspecting the element the button is there with the proper link in the html: 'More'. I even tried changing the z-index in my child's css thinking that was the problem but that had no affect.

    Just to clarify I am using Customizr 3.09 w/ WP 3.8.

    Here is the link to my site:
    http://www.biologydesign.com/websites

    Between this not working and the inability to change the max character length of the slider text (when changing the associated values in class-admin-meta_boxes.php) slider is quickly becoming obsolete for what I need to do on this site.

    Any help from someone who had and solved this issue would be greatly appreciated.

  2. nikeo
    Member
    Theme Author

    Posted 8 months ago #

    Hi @Seahwksean, first of all let me congratulate you for this webdesign!
    This looks just awesome and is truly one of the best Customizr based website I've seen!

    About your button hovering issue, this is a z-index related problem, just add the following CSS code :

    #customizr-slider {
    position: relative;
    z-index: 0;
    }

    For the max number of character in the slider, there's a filter designed just for that (but I am not sure it was there in v3.0.9)

    apply_filters( 'tc_slide_text_length', 250 );

    I would love to add your website to the showcase, feel free to submit it here : http://www.themesandco.com/customizr-showcase-submission-form/

    Thanks

  3. Seahawksean
    Member
    Posted 8 months ago #

    Of course!! Your advice worked! :-D I should have thought of moving #customizr-slider down instead of just trying to move the .carousel-caption .btn up using z-index! Sorry to take up your time.

    Thank you so much for your kind words, nikeo! I'm really proud of the site. Your theme is great. This is the second site in which I've used Customizr. I've always been able to eventually work out issues and get it to look/do exactly what I want it to do. In major part to you and others like ElecticFeet and rdellconsulting. Couldn't have done it without you.

    As soon as the site is completely done I will certainly post it to the showcase.

  4. rise14
    Member
    Posted 8 months ago #

    Haven't tried this yet myself but thanks for all of the responses guys.

  5. mrroast
    Member
    Posted 8 months ago #

    Seahawksean,

    looking at your website (http://www.biologydesign.com/websites/) it looks good but your pictures are huge.
    I suggest you don't use png. Use jpeg with 60-80 quality. That should help your page load faster with slower connections and use less bandwidth.

Reply

You must log in to post.

About this Theme

About this Topic