WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Gallery
[resolved] Slide Show doesn't work on main URL page (7 posts)

  1. Mallycat
    Member
    Posted 1 year ago #

    I think there may be a bug in the current release.

    I have the following code on my home page http://boroniaparkframing.com.au

    [nggallery id=7]

    It renders correctly as thumbnails, but when I click on "show as slideshow", it comes up with a "page not found" error.

    If I put exactly the same code on another page. i.e. http://boroniaparkframing.com.au/test then all works 100%

    Any thoughts? Is this a bug?

    http://wordpress.org/extend/plugins/nextgen-gallery/

  2. smigliorato
    Member
    Posted 1 year ago #

    Two quick questions:

    Did it ever work on the front page? If yes, what else changed? Any other plugin/theme updates?

    If no, continue to the question below.

    On your theme, how do you set your home page?

    Did you create a page, and then go into WordPress Settings->Reading and set up your front page to use a static page?

    Check that setting and see what it is set to.

    There is a possibility that your theme decided to do its own thing for your home page. This might mean Settings->Reading is set to "Latest Blog Posts" even though you have a static front page.

    Let me know if that's the case.

  3. Mallycat
    Member
    Posted 1 year ago #

    No I did not get it working.

    my wp site is installed in the main domain. http://boroniaparkframing.com.au

    I checked the settings you refered to, and they are both set to http://boroniaparkframing.com.au which seems correct to me.

    However, taking this as a lead, I changed the second setting to be http://boroniaparkframing.com.au/index.php and then it worked.

    I would have thought it should work without having to add index.php. I don't want to 'dumb down' my site to add the index.php to get this to work.

  4. smigliorato
    Member
    Posted 1 year ago #

    I was poking around and the issue is with ?show=slide that appears at the end of the url.

    That is the bit of code NextGen uses to activate the slideshow.

    Since you mentioned the slideshow works on other pages, it would appear the problem isn't necessarily with NextGen, but the theme/settings/etc.

    Was there a time when the slideshow link worked on your front page? Or, is this a new site, and you've never had a working slideshow there?

    ***
    Just a note, if you want an easy fix, just disable the slideshow link. No slideshows, but you won't have to chase down this error.
    ***

    I just want to confirm, on the WordPress Settings->Reading page, do you have either:

    • Latest Blog Posts
    • A static page (select below)

    checked. If static is checked, what pages have you selected in the two dropdown boxes. You shouldn't select the same page in both, it should give you a warning if you do. It can cause issues.

    Also, what do you have selected in Settings->Permalinks? If your using a custom structure, what exactly is in the custom structure box?

  5. Mallycat
    Member
    Posted 1 year ago #

    Tanks for your ongoing help.

    I have a statice page for the home page. The page is called "home". I have no page set for blogs, as I don't use blog pages.

    The permalink setting is for "post"

    I would be happy to disable the sideshow setting, but I do t know how. Can you help?

  6. smigliorato
    Member
    Posted 1 year ago #

    Ahhh yes, that will be easy.

    Go to Gallery->Options. Then, go to the Gallery tab.

    There is a setting called

    Integrate slideshow

    Just uncheck the box and the slideshow link will be gone.

  7. Mallycat
    Member
    Posted 1 year ago #

    Great, that did it - thanks

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.