WordPress.org

Ready to get started?Download WordPress

Forums

tf Song List
[resolved] Slashes next to apostrophes ex: DON\'T (5 posts)

  1. david@clevelandesigns.com
    Member
    Posted 11 months ago #

    Every time there is a song listed with an apostrophe a slash appears next to it. I thought this might have been because I imported a CSV file but even if I create a new song manually it does the same thing. Can you help with this please? Here is a link to the site where you can see it.

    http://lifesupportband.com/songlist/

    http://wordpress.org/plugins/tf-song-list/

  2. david@clevelandesigns.com
    Member
    Posted 11 months ago #

    Oh, also if you notice, there are unexplained space differences between songs. I'm not sure why but any help on that would be appreciated too.

  3. david@clevelandesigns.com
    Member
    Posted 11 months ago #

    it appears that this call might be in the PHP somewhere "addslashes()"

  4. ipm-frommen
    Member
    Plugin Author

    Posted 11 months ago #

    I already answered this via e-mail, but I will add this here as well.

    What you call "unusual, random spacing" is, in fact, spacing before a group of songs starting with a new first letter (e.g., after all songs starting with an A, there's some space before the group of songs starting with the letter B, and so on...).

    To turn off this behavior, take a look at the FAQ:
    -> http://ipm-frommen.de/wordpress/tf-song-list#faq

    In short, add the following to your stylesheet:

    /* Song row style for new first letter */
    #tfsl-the-list tr.new-first-letter td {
    padding-top: 0;
    }

    As for the apostrophes and slashes: I have updated the plugin.
    Since WordPress automatically add slashes to $_POST data, the songs added by hand (and not via import) were escaped twice, while unescaped only once.

  5. david@clevelandesigns.com
    Member
    Posted 11 months ago #

    terrific, thank you. After posting this I did notice that it was spacing after each first letter change. Thank you for the CSS to remove it, worked great. Also, thanks for the update to get rid of that slash. Much appreciated.

Reply

You must log in to post.

About this Plugin

About this Topic