WordPress.org

Ready to get started?Download WordPress

Forums

slash needed when moving wp to the root (4 posts)

  1. Glenn S
    Member
    Posted 1 year ago #

    Hi everyone.

    I'm having an issue pointing a wp install from a subfolder to the root.

    I've followed the codex and copied and edited the index.php from the folder where the install, is over to the root after downloading it and editing the blog-header reference:

    from: require('./wp-blog-header.php');
    to: require('./en/cms/wp-blog-header.php');

    I don't have permalinks set, and no htaccess file was found anyway when I checked for hidden files on the server so this is the only file I believe that needed to be edited.

    When I type in domain.com/ (using an ending slash after the domain name) the wordpress site comes up. So far so good - I suspected the ending slash might have something to do with the problem but I'm not sure why. Also, my host settings (dreamhost) are using 'change domain.com to http://www.domain.com. WordPress is also using www for both the install and the site location.

    However, if I leave off the ending slash and just type in the domain name, I get a blank page which doesn't display an error of any sort (perhaps it's a totally white graphic as content, because inspecting the page elements reveals a jpg and a css file being accessed). The index.php is the only file in the root folder except for favicon.ico and favicon.gif files. There are no htm or any other files there -- I also looked in the wordpress and other folders on the domain and didn't notice any strange files there either.

    Would be great to be able to troubleshoot this strange problem. Thank you all.

  2. Abhishek Ghosh
    Member
    Posted 1 year ago #

    That is our famous Giving WordPress Its Own Directory -

    http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory#Using_a_pre-existing_subdirectory_install

    You have followed it.

    Please cross check with my re-written version what you have done (check in cool head) :

    http://thecustomizewindows.com/2012/12/wordpress-subfolder-installation-to-root-for-pre-existing-installation/

    It will definitely work. Please report us what is line in that Giving WordPress Its Own Directory official guide that is actually not clear to you (we will edit it to easy to understand language or add screenshot).

    The reason I rewrote on my website is actually for couple of similar complains. I guess there is the extra slash issue in wp settings page, probably Giving WordPress Its Own Directory needs a bit clarification ?

    As it is a Free Software, we the users have to contribute to make it more better.

  3. Glenn S
    Member
    Posted 1 year ago #

    Hmm.

    Abhishek, thank you. I noticed the backslash following your blog address url on the image on your site page that you referenced.

    I dabbled and added a backslash following my blog address url and also site url just to try this. When I saved the settings in the admin, the backslashes disappeared as if some filter in wp wouldn't allow them, but I checked the site page anyway (using just the root url) and it worked! So I'm definitely happy with this, but of course not totally sure why.

    Anyway, thank you for your help.

  4. Abhishek Ghosh
    Member
    Posted 1 year ago #

    Many thanks to you too Glenn S for the feedback.
    We have to add a screenshot on the Giving WordPress Its Own Directory documentation. Basically in words sometimes the things can not expressed rightly !

    Regarding the backslash. It is normal with the thing you are getting. Your assumption is probably right.

    Enjoy this new year with fixed WordPress.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.