WordPress.org

Ready to get started?Download WordPress

Forums

Slash is missing at the end of domain (11 posts)

  1. anamul.palash
    Member
    Posted 11 months ago #

    Recently I've moved my WordPress multisite to a self-setup CentOS server which I've setup by on my PC. After transferring, the it is missing a "/" (slash) right after the domain name.
    when I'm trying to access network admin page, the url is like: http://wapx.bizwp-admin/network/ which was ought to be http://wapx.biz/wp-admin/network/
    same kind of problem with all sites, like http://wapx.bizoutreach which would be actually http://wapx.biz/outreach
    I've used Search and Replace in database to add a "/" for wp-contents and blogs but I cannot create new site for this problem and many links are missing.
    Any suggestion please?

  2. Recently I've moved my WordPress multisite to a self-setup CentOS server which I've setup by on my PC.

    Full stop.

    HOW did you move? Which search/replace tool did you use to change the domain name?

  3. anamul.palash
    Member
    Posted 11 months ago #

    I've Exported the whole database from my existing site's phpMyAdmin, transferred all my files and folders from existing site's directory to the new location, created new database, inserted the existing database into new one and used this php script from http://interconnectit.com/products/search-and-replace-for-wordpress-databases/ to replace existing domain name with new one from wp_options, wp_blogs and wp_posts table.

  4. Awesome :D I have to ask, because SOOOOOO many people do that in a weird way.

    After transferring, the it is missing a "/" (slash) right after the domain name.

    Okay, in your wp_blogs table, what do you have for the PATH of than primary site?

  5. anamul.palash
    Member
    Posted 11 months ago #

    Its blank for primary site.

  6. Put in a / :)

  7. anamul.palash
    Member
    Posted 11 months ago #

    I thought you'd suggest me to to put a slash there. I tried it long ago, and then the database become unknown to my site :D
    actually the / is missing in some area, not everywhere! I've put the slash manually at some place. At some url it works after putting slash, and at some url, yet it gives me 404 error even if I put / manually in the url from database.

    You're being too kind with your suggestion, so I believe you wont mind if I upload some screenshot of database showing problem scenario :)
    Thanks

  8. anamul.palash
    Member
    Posted 11 months ago #

  9. I ONLY meant for you to put the / for blog #1 Mine all look like this: http://cl.ly/image/360D1m0A3N21

    What do you have in there for wp_site?

    It should be

    domain: domain.com
    path: /

  10. clevelandstate
    Member
    Posted 11 months ago #

    I'm having this same issue, but with a new install of wordpress (3.5.2) multisite using sub directories.

    My wp-config and .htaccess match what was given on the Network Settings page and the db has:
    domain: blogs.domain.com
    path: /

  11. Paul Barthmaier
    Contributor Day Volunteer
    Posted 11 months ago #

    Hey ClevelandState,

    Can you create your own thread? It's easier for the volunteers to keep track that way.

Reply

You must log in to post.

About this Topic