WordPress.org

Ready to get started?Download WordPress

Forums

Shashin
[resolved] Size of inserted photos has shrunk. (9 posts)

  1. EvilPharmacist
    Member
    Posted 10 months ago #

    Hi,

    Just updated to the latest version 3.4.
    I noticed that the photos I had added to posts had shrunk.
    For example, a photo added using this tag:
    [shashin type="photo" id="3545" size="small" columns="max" order="user" position="left"]
    ends up like this:

    <div class="shashinTableRow">
    <div class="shashinTableCell" data-original_width="29%" style=" width: 29%; max-width: 150px;"><a href="https://lh3.googleusercontent.com/-LjShWWVYt4c/UgANiBYGucI/AAAAAAAAPAA/FPiLaLhIAC4/IMG_1493.JPG?imgmax=1024" id="shashinThumbnailLink_1" data-ShashinPhoto="3545" rel="prettyPhoto[1]" title="Afgemeerd op Haringvreter voor de nacht (we mochten er eigenlijk niet liggen...)"><img src="http://lh3.googleusercontent.com/-LjShWWVYt4c/UgANiBYGucI/AAAAAAAAPAA/FPiLaLhIAC4/IMG_1493.JPG?imgmax=150" alt="Afgemeerd op Haringvreter voor de nacht (we mochten er eigenlijk niet liggen...)" title="Afgemeerd op Haringvreter voor de nacht (we mochten er eigenlijk niet liggen...)" width="150" class="shashinThumbnailImage" id="shashinThumbnailImage_1" /></a><div class="shashinPrettyphotoCaptionWrapper" id="shashinPrettyphotoCaption_1">
    <div class="shashinPrettyPhotoCaption">
    Afgemeerd op Haringvreter voor de nacht (we mochten er eigenlijk niet liggen...)<span class="shashinCaptionExif">03-Aug-2013 20:25, Canon Canon EOS 60D, 8.0, 18.0mm, 0.003 sec, ISO 100</span><div class="shashinLinkToOriginalPhoto"><a href="https://picasaweb.google.com/107145053621792757280/130803VeerseMeerWeekend#5908737589246343618">View at Picasa</a></div>
    </div></div>

    Somewhere in there you can see this:
    style=" width: 29%; max-width: 150px;"
    which is making the photos really small (29%). How can I fix this?

    http://wordpress.org/plugins/shashin/

  2. Mike Toppa
    Member
    Plugin Author

    Posted 10 months ago #

    How many photos are in the row? I'm guessing 3. Go to the Shashin settings page, and check the width for "Content width (in pixels) for your theme". If you make this number larger, Shashin will allow more width for each photo, or you can reduce the number of columns per row (change columns="max" in the shortcode to 1 or 2).

  3. EvilPharmacist
    Member
    Posted 10 months ago #

    Well, there's only one photo, the shortcode is above.
    You can see my website at http://www.niek.be. You can see that the photos inserted with shashin are too small.

    The "Content width (in pixels) for your theme" setting is set to 600px. But I don't think it relates to this problem.
    Somehow the 'width: 29%' gets added in the shashinTableCell div, which is the culprit...

  4. Mike Toppa
    Member
    Plugin Author

    Posted 10 months ago #

    I see what you mean. Can you try changing columns="max" to columns="1" and let me know if that helps? I'm guessing there is a problem with how Shashin is interpreting "max" here (Shashin is adding that percentage width, but it's inappropriate in this case)

  5. EvilPharmacist
    Member
    Posted 10 months ago #

    Changing max to 1 does help indeed.
    Is this a feature or a bug? Because I have these shortcodes in a lot of posts so if possible I'd like to avoid having to change all my posts.
    It must have been different in previous versions, because this started to happen after the last update.

  6. Mike Toppa
    Member
    Plugin Author

    Posted 10 months ago #

    It's a bug. max should equal 1 in this case (since there is only 1 photo to show), but since the percentage is 29%, that tells me it's probably 3, which is wrong. I'll get it fixed this weekend. Thanks for letting me know.

  7. EvilPharmacist
    Member
    Posted 10 months ago #

    No problem. Thanks for addressing this so quickly!
    I've reported bugs before (through your website's comment section) and you've always been very quick in fixing them.
    I'll make a donation!

  8. Mike Toppa
    Member
    Plugin Author

    Posted 10 months ago #

    I've uploaded version 3.4.1, which fixes this

  9. EvilPharmacist
    Member
    Posted 10 months ago #

    Splendid, thanks!

Reply

You must log in to post.

About this Plugin

About this Topic