WordPress.org

Ready to get started?Download WordPress

Forums

WordPress MU Sitewide Tags Pages
[resolved] Sitewide tags creating duplicate categories in tags blog (68 posts)

  1. Rob
    Member
    Posted 2 years ago #

    Ron,

    I've confirmed that the categories in my tags blog are identical to those in the source blog, including case usage, yet duplicate (but empty) categories are being created with each new post or post update.

    -Rob

  2. Ron Rennick
    MultiSite Guru
    Plugin Author

    Posted 2 years ago #

    Sorry, I did not notice you said you were using the 0.4.1.1 version. Once a version is released no further changes are made to it. If it has bugs those bugs will remain in that version in perpetuity.

    Current work on addressing the issue is in the development version of SWT: http://wordpress.org/extend/plugins/wordpress-mu-sitewide-tags/download/

  3. Ron Rennick
    MultiSite Guru
    Plugin Author

    Posted 2 years ago #

    @nearlyjen - give the dev version a try with different cases in the category name/title.

  4. nearlyjen
    Member
    Posted 2 years ago #

    Hi Ron,

    Testing starting. All tags blog categories have at least one post.

    1st test (blog = JCROSS) = posted using three categories. All three categories already exist in the tags blog. No duplicates were created, even with different cases in category name.

    2nd test (blog = eProjects) = posted using three categories. Two categories already exist in the tags blog and one does not.

    **In the tags blog, this post is only placed in the two pre-existing categories. Also, the third category is created as an empty duplicate (name=Photos, slug = photos-2) even though there was no Photos category to duplicate.

    Email me if I've explained poorly or screenshots would help :)

    Jen

  5. Ron Rennick
    MultiSite Guru
    Plugin Author

    Posted 2 years ago #

    Thanks Jen - I'll see if I can reproduce.

  6. Ron Rennick
    MultiSite Guru
    Plugin Author

    Posted 2 years ago #

    Finally got back to this. I tried to reproduce with no luck. I created a new category that didn't exist anywhere in the install. Categories were applied correctly and no duplicate category.

  7. wadams92101
    Member
    Posted 2 years ago #

    It created a duplicate category for me too (on the main blog) upon publication of the post. I kept tinkering with it deleting the duplicate on the main and on the child, recreating the category on the child, then updating the post - finally, it stopped. Don't know what the issue was exactly. I noticed that that on the other child blogs the category ID was different and when the problem resolved, the category ID was the same. I also deactivated a couple of plugins (multi-post, which this plugin replaces anyway, and nicasio dynamic headers) It was just happening with one particular category - not others so may be it was something in the way I set up the category in the child. Also, when the problem was happening, my Dynamic Content Gallery widget, which was set to show that category, would not show that post. So obviously, it wasn't recognizing the duplicate. Hope this helps.

  8. Ron Rennick
    MultiSite Guru
    Plugin Author

    Posted 2 years ago #

    This thread was related to a previous version of SWT.

    SWT is designed to not use child categories in the tags blog to prevent issues with conflicts between children categories with different parents in different source sites.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic