WordPress.org

Ready to get started?Download WordPress

Forums

sitewide search problem (2 posts)

  1. bpetruzzo
    Member
    Posted 6 years ago #

    I've installed the sitewide search plugin which seems to be working fine, except if there are no results to display. If I search for something that returns no results I get this:

    Warning: rsort() expects parameter 1 to be array, null given in /home/petruzzo/public_html/underthesun/wp-content/mu-plugins/gt_search_all_blogs.php on line 120

    Warning: reset() [function.reset]: Passed variable is not an array or object in /home/petruzzo/public_html/underthesun/wp-content/mu-plugins/gt_search_all_blogs.php on line 121

    Unfortunately, I don't know enough to be able to debug this. Anyone know outright what to do?

  2. scribblerguy
    Member
    Posted 6 years ago #

    .../wp-content/mu-plugins/gt_search_all_blogs

    Are you using WordPress MU (multi-user)? If so, they have their own forums:
    WordPress MU Forums.

    If you just have one blog or a few WordPress sites, then 'classic' WordPress is what you want. WordPressMU isn't designed for the average user.

    I checked william.petruzzo.com, that meta tags list the generator as WordPress 2.5.1, which is the 'classic' version.

    WordPress 2.5.x now searches all posts and pages automatically. If you've somehow installed an MU plugin in WP 'classic,' then you'll need to remove and uninstall that plugin.

Topic Closed

This topic has been closed to new replies.

About this Topic