WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] sitemap.xml issues - please help (7 posts)

  1. saintgiles
    Member
    Posted 1 year ago #

    I originally installed my site in a subdirectory at http://www.stgiles-moraga.org/wordpress/

    I just moved everything to the root directory and updated all the links and paths and everything using Velvet Blues Update URLs and the URI is all set and (almost) everything is working.

    I get an error with my sitemap.xml file, though, which is created using Google XML Sitemaps v. 3.2.8 by Arne Brachhold. Here's the sitemap: http://www.stgiles-moraga.org/sitemap.xml

    Here's the error:

    Error loading stylesheet: A network error occurred loading an XSLT stylesheet:http://www.stgiles-moraga.org/wordpress/wp-content/plugins/google-sitemap-generator/sitemap.xsl

    it's still looking for that generator under the subdirectory for some reason, and I can't find where to change it so it knows instead to look here: http://www.stgiles-moraga.org/wp-content/plugins/google-sitemap-generator/sitemap.xsl

    Any ideas? I tried uninstalling and reinstalling Google XML Sitemaps plugin but that doesn't work. Is there any easy fix, or should I just use another XML sitemap generator? Any help you can offer would be great.

    Rev. Justin

  2. Delete and reinstall the Google XML Sitemaps plugin; looks like an error with it. If that doesn't wotk, Clean Options to get rid of the old plugin options and reinstall the plugin.

  3. saintgiles
    Member
    Posted 1 year ago #

    Deleting it and reinstalling the plugin doesn't seem to work. When I run Clean Options I'm not sure which options to remove.

    I am wondering if I shouldn't just copy/paste the google-sitemap-generator folder into that old location, OR install a different Google Sitemap creator????

    Any suggestions?

  4. saintgiles
    Member
    Posted 1 year ago #

    I think I got it fixed. Please confirm:
    http://www.stgiles-moraga.org/sitemap.xml

  5. Looks like it.

    FYI, all your pages that have the -2 slug means that there is a page with the same name in the trash. Empty the trash and then change the published page slugs to get rid of the -2.

  6. saintgiles
    Member
    Posted 1 year ago #

    How do I empty the trash and change the slugs?

  7. saintgiles
    Member
    Posted 1 year ago #

    I figured out trash, but there's nothing in the trash. I deleted some old drafts, they went into the trash, and I emptied it. I changed the ministries page to not have -2, and it seems that may have fixed it. Let me know.

Topic Closed

This topic has been closed to new replies.

About this Topic