WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
[resolved] Sitemaps given a 404 not found error (9 posts)

  1. purplebabyhippo
    Member
    Posted 9 months ago #

    I have several wordpress websites and since updating to WordPress V 3.71 and Yoast SEO V 1.4.19 they all display a 404 not found error for the sitemaps.
    I tried deactivated plugins and changing the theme to the default twentythirteen but the error still existed.
    My sites run various themes including Genesis Child and Twentytwelve.
    When I reverted back to Yoast SEO Plugin V 1.4.18 with WordPress V 3.71 it works.

    http://wordpress.org/plugins/wordpress-seo/

  2. djsmuggla
    Member
    Posted 9 months ago #

    I had the same problem that i've just solved, try this:
    http://wordpress.org/support/topic/missing-sitemap-after-upgrade?replies=2

  3. purplebabyhippo
    Member
    Posted 9 months ago #

    Thanks, however I did try this when I first had the problem but it didn't make any difference.

  4. purplebabyhippo
    Member
    Posted 9 months ago #

    Today I have install a new wordpress website version 3.71 with Yoast SEO as the only plugin and I still got a 404 error for the sitemap. I put the code below in my Htaccess file before the wordpress rules as recommended by Yoast and now I get a blank white screen. I cannot get this to work on any of my sites since WordPress 3.71 - does anyone know what is causing this issue?

    # WordPress SEO - XML Sitemap Rewrite Fix
    RewriteEngine On
    RewriteBase /
    RewriteRule ^sitemap_index.xml$ /index.php?sitemap=1 [L]
    RewriteRule ^([^/]+?)-sitemap([0-9]+)?.xml$ /index.php?sitemap=$1&sitemap_n=$2 [L]
    RewriteRule ^([a-z]+)?-?sitemap.xsl$ /index.php?xsl=$1 [L]
    # END WordPress SEO - XML Sitemap Rewrite Fix

  5. purplebabyhippo
    Member
    Posted 9 months ago #

    I have found a series of events which fixes my problem:
    1. Add Sitemap Rewrite Fix rules to very beginning of HTaccess (as above)
    This gives me a blank white sitemap page
    2. Uncheck enable Sitemap functionality on the Yoast SEO Plugin & Save
    3. Check Sitemap functionality & save

    I now have my sitemaps back!
    I hope this helps

  6. jasonsaulnier
    Member
    Posted 9 months ago #

    I am having problems as well with my sitemap.

  7. JohnMrC
    Member
    Posted 9 months ago #

    Same here

    On Webmaster tools,I get :

    Parsing error
    We were unable to read your Sitemap. It may contain an entry we are unable to recognize. Please validate your Sitemap before resubmitting.

  8. Adrià López
    Member
    Posted 9 months ago #

    Not working for me :(

  9. JohnMrC
    Member
    Posted 9 months ago #

    I have found a series of events which fixes my problem:
    1. Add Sitemap Rewrite Fix rules to very beginning of HTaccess (as above)
    This gives me a blank white sitemap page
    2. Uncheck enable Sitemap functionality on the Yoast SEO Plugin & Save
    3. Check Sitemap functionality & save

    I now have my sitemaps back!
    I hope this helps

    This does not work for me either

Reply

You must log in to post.

About this Plugin

About this Topic