WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
Sitemap_index.xml 404'ing after 3.6 update (5 posts)

  1. Ivan
    Member
    Posted 11 months ago #

    I'm not able to generate (or at least find) my sitemap_index.xml after the most recent update. I know W3 Total Cache can be a problem, so I've added the exceptions that are stated on yoast.com. I've also tried deactivating the plugin altogether but to no avail.

    Is anyone else having this issue? Any ideas?

    Edit - The domain in question is http://molliepop.com

  2. ls41
    Member
    Posted 11 months ago #

    I have the same problem

    Error loading stylesheet: A network error occurred loading an XSLT stylesheet:http://www.example.com/sitemap.xsl

  3. littler.chicken
    Member
    Posted 11 months ago #

    My sitemap is also throwing a 404--a new site running 3.6. I do not have a caching plugin installed.

    signalpres.org (link to sitemap/404)

    On a development site (same plugins, themes, etc.), I verified that the issue was happening. Added the .htaccess fix from the Yoast FAQ page, sitemap was still misbehaving. Deactivated the sitemap functionality and then reactivated it, and on the development site, it's now working.

    I also erroneously put Yoast's SEO fix code AFTER the WordPress rules in my .htaccess (because I was hurrying and not reading, my bad), and once I moved it, disabled the sitemap, and re-enabled it, my sitemap started working on the live site. So hopefully my error will help someone else.

  4. Chris
    Member
    Posted 11 months ago #

    Yes 3.6 screws up the XML file setup. For some reason the XML stops working after the upgrade. Just needs to be re-saved.

    The fix was simple:
    - All I did was go into the plugin.
    - Select XML plugin from the menu.
    - Under exclude post types, I just selected a random one "Posts"
    - Save the file.
    - Went back into the same menu. This time unticked "Posts"
    - Save the file

    XML File was back online.

    Basically the settings needs to be saved using a different parameter.
    Hope it helps.

  5. Ivan
    Member
    Posted 11 months ago #

    Thanks for all the replies, everyone! I've gone about troubleshooting the issue using the above ideas as well as a few additional ones.

    Placing the Rewrite rules from Yoast's FAQ page didn't do the trick for me. Even after restarting the plugin, clearing caches etc.

    The WordPress SEO plugin has gone through an update since the original post, and it did change the error message for me. It now reads 'Error loading stylesheet: An XSLT stylesheet does not have an XML mimetype:'

    I also went through the process of placing
    AddType application/xml .xsl
    per this WordPress forum post. That didn't work for me either.

    What I ended up doing was downloading the sitemap.xml from the server via FTP, once it was open I noticed that there was a line in there referencing an XSL stylesheet, clearly I don't need the sitemap to look pretty for Google to recognize it. Therefore I just removed the line and re-uploaded. With that done I can now view the /sitemap.xml even if I still can't see /sitemap_index.xml.

    Hopefully that helps someone!

Reply

You must log in to post.

About this Plugin

About this Topic