WordPress.org

Ready to get started?Download WordPress

Forums

All in One SEO Pack
[resolved] Sitemap now giving a 404 error code (3 posts)

  1. David
    Member
    Posted 9 months ago #

    I had /sitemap.xml URL setup fine, but I clicked "activate" in All in one SEO pack for the XML sitemap generator. It said there was a conflict in the naming structure (or something like that) and I should rename it or ignore. I chose to rename, thinking it would just overwrite and work, however, now my /sitemap.xml no longer works. My sitemap gives a 404 error code.

    I was able to figure out the old file was renamed to /sitemap.xml._000.old, which works, but again, /sitemap.xml does not work and gives me a 404 error code. I have tried deactivating the XML Sitemap in All in One SEO but that doesn't fix it.

    How do I get the /sitemap.xml file to show the correct sitemap results?

    Thanks, David.

    http://wordpress.org/plugins/all-in-one-seo-pack/

  2. Peter Baylies
    Member
    Plugin Author

    Posted 9 months ago #

    davidroose,

    There are two methods you can use to serve a sitemap.xml file here; one method is having it dynamically generated for you. If you choose to do this, you don't need an actual sitemap.xml file present on your server, it will be generated by WordPress when the page is accessed. If you have this set, then try going to Settings -> Permalinks to refresh your permalinks, and then see if you can browse to sitemap.xml and if a sitemap is generated. If this doesn't work, then for whatever reason the dynamic sitemap option isn't working for you - you'll want to uncheck the "Dynamically Generate Sitemap" option and click the "Update Sitemap" button in the XML Sitemap settings. This will generate a static sitemap.xml file for you on the filesystem.

  3. David
    Member
    Posted 9 months ago #

    thanks.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.