WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
sitemap not working (8 posts)

  1. Viktor Nagornyy
    Member
    Posted 3 years ago #

    It seems like sitemap doesn't work for some reason. Google Webmaster Tools doesn't recognize it. Any ideas why? Here's the link.
    http://www.viktorix.com/sitemap.xml

    It seems like in source code its there, but it won't work or display.

    Thanks a lot,
    Viktor

  2. Derek
    Member
    Posted 3 years ago #

    Are you using a plugin to create the sitemap?

    Derek Fox

  3. Joost de Valk
    Member
    Plugin Author

    Posted 3 years ago #

    As the post is tagged "WordPress SEO" I'm assuming he's using my plugin :) the xml sitemap works fine, the XSLT doesn't. Wait a bit for 0.4 this week to come out, it has a complete new way of doing XML Sitemaps anyway as the current one is bug prone.

  4. Viktor Nagornyy
    Member
    Posted 3 years ago #

    Looking forward to the fix. Thanks Joost.

  5. Joost de Valk
    Member
    Plugin Author

    Posted 3 years ago #

    You should, almost there ;)

  6. Viktor Nagornyy
    Member
    Posted 3 years ago #

    Hey,
    Just follow up on this. I see sitemap feature is different, so I assume it should be fixed?

    When I go to my sitemap based on the link you have /sitemap_index.xml it redirects me to the homepage. Is this normal?

    Thanks for your help!

  7. Hector
    Member
    Posted 3 years ago #

    When I go to sitemap_index.xml I get a 404. I am on Nginx which makes me think I need to manually write a redirection rule? Any help will be veryyyyyy welcome.

  8. Joost de Valk
    Member
    Plugin Author

    Posted 3 years ago #

    Check this new post: http://yoast.com/xml-sitemap-in-the-wordpress-seo-plugin/, this should answer all your questions / issues.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic