WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
Sitemap HTML (7 posts)

  1. Npalexande
    Member
    Posted 6 months ago #

    when i try to add the site map that Yoast generated into my google web masters page i get this error message:

    "Your Sitemap appears to be an HTML page. Please use a supported sitemap format instead."

    does anyone know what i'm doing wrong?

    http://wordpress.org/plugins/wordpress-seo/

  2. CBSE Date Sheet 2014
    Member
    Posted 6 months ago #

    Your Sitemap appears to be an HTML page. Please use a supported sitemap format instead.
    The issue is, the Sitemap files are auto generated by Google Sites. The help document explains:

    Your sitemap_index.xml is in the page cache of W3 Total Cache. I would just exclude the sitemap_index.xml and all other sitemaps (post-sitemap.xml, page-sitemap.xml, category-sitemap.xml, post_tag-sitemap.xml,ngg_tag-sitemap.xml ) from the page cache. Hsbte result

    Hope this helps

  3. dt125x
    Member
    Posted 6 months ago #

    Did anyone solve this problem and how ?

    Is page_sitemap the only sitemap I should have? Is this a primary sitemap? On some other sitemaps I have this error but on this one i do not... Is it enough to delete all the others and leave page_sitemap.xml ?

  4. MoghillPat
    Member
    Posted 6 months ago #

    Just encountered this issue for the first time also - html in sitemap files, even though there were no errors on testing the sitemap.

    However, when I came back into webmaster tools a few minutes later the sitemap was fine - no errors reported.

    So I'm thinking this is a Google issue, not a Yoast issue, and it resolves itself quickly. So I would wait and see, then have another look it Webmaster Tools - it may just (somehow) fix itself.

  5. Fiontain
    Member
    Posted 5 months ago #

    I have having the same error with the sitemap_posts. Google webmaster tools see it with an error. Resubmitted the sitemap again. No difference.

  6. dt125x
    Member
    Posted 5 months ago #

    I am having this issue with two different theme on two different pages totaly separated...

    So i think it is a yoast problem and I am not satisfied becoues of this problem... I hope yoast team will solve the problem because I see a lot of people have it...

  7. Fiontain
    Member
    Posted 5 months ago #

    Hi. I checked Google Webmaster tools a few minutes ago and my sitemap_posts is fine now. So I have a feeling it might be Google with the problem. Resubmit the particular sitemap again.

Reply

You must log in to post.

About this Plugin

About this Topic