WordPress.org

Ready to get started?Download WordPress

Forums

sitemap 404 error (19 posts)

  1. l0zo
    Member
    Posted 7 years ago #

    I have installed the sitemap (http://www.arnebrachhold.de/redir/sitemap-dl-en/) in my server, and activated it on wordpress. Then i pressed the "rebuild" button. And I still get a 404 error(http://skurfboards.com/sitemap.xml).

    Do I need to add any other files that didnt come with the plugin?

    What is this CHMOD thing?

  2. blogosquare
    Member
    Posted 7 years ago #

    Could you be a bit more precise please? where did you get the 404 error? is it when visiting the sitemap, building it...etc?

  3. l0zo
    Member
    Posted 7 years ago #

    I have a different error now, I have installed the sitemap (http://www.arnebrachhold.de/redir/sitemap-dl-en/) in my server, and activated it on wordpress. Then i pressed the "rebuild" button. But when i go to http://skurfboards.com/sitemap.xml I get this error

    "XML Parsing Error: no element found
    Location: http://skurfboards.com/sitemap.xml
    Line Number 1, Column 1:"

    I've been trying to get this sitemap working for so long!

  4. frotzed
    Member
    Posted 7 years ago #

    That site you linked for the plugin doesn't work for me. Are you sure it's correct?

  5. frotzed
    Member
    Posted 7 years ago #

    Is it the plugin for the google sitemap? or the a9 sitemap?

  6. frotzed
    Member
    Posted 7 years ago #

    nevermind, I see you linked to the plugin itself. d'oh. Let me install a local copy of the plugin and see how I get it working.

  7. frotzed
    Member
    Posted 7 years ago #

    OK. I got it to work. when you press the "rebuild button" do you see the same thing that I do here?
    clicky

  8. frotzed
    Member
    Posted 7 years ago #

    If you don't see that then you need to make sure that your root directory is writable. I'd try setting the CHMOD to 755 or *maybe* 777.

    The CHMOD thing is explained like this: "A UNIX command that changes the mode of a file. There are three modes a file can have turned on or off: read ability, write ability, and execute ability. Each mode can be set for either the owner, the members of the owner's group, or all users." Changing the chmod of the root directory to 755 or 777 basically allows the google sitemap plugin to create the necessary xml and xml.gz files there.

  9. Jonathan Landrum
    Member
    Posted 7 years ago #

    I'd go with 755. Paranoid for a reason. ;o)

  10. frotzed
    Member
    Posted 7 years ago #

    I would go with 755 too. The only reason I said *maybe* is because I was once on a server that for some odd reason insisted that I set it 777. It was very odd.

  11. l0zo
    Member
    Posted 7 years ago #

    When I click rebuild nothing happens "look here. I set sitemap.php to 755. Do I need to add sitemap.xml sitemap.xml.gz anywhere? There must be something really small thats missing. Frotzed do you have a messenger I can speak to you on?

  12. frotzed
    Member
    Posted 7 years ago #

    I'm about to go to bed so I can't talk right now, but for future reference you can catch me on gtalk under the username "frotzed".

    Setting your sitemap.php file permissions differently won't change anything, that was a good thought though. I see in your screenshot (which was incredibly helpful) that you don't have any of the options checked. See my screenshot here. Make sure you've got most, if not all, of those boxes checked and then hit "rebuild."

  13. frotzed
    Member
    Posted 7 years ago #

    But no, you don't need to manually create those files, the plugin does that.

  14. l0zo
    Member
    Posted 7 years ago #

    I checked most of the options, but now have a new error haha here Im on mac so dont have gtalk. Could it be a problem with sitemap that Im on a mac?

  15. Jonathan Landrum
    Member
    Posted 7 years ago #

    Just for kicks, go ahead and make the two files and see what happens.

  16. l0zo
    Member
    Posted 7 years ago #

    I made to files and nothing..

  17. Jonathan Landrum
    Member
    Posted 7 years ago #

    I set sitemap.php to 755.

    No, the plugin doesn't need special permission. You can keep it 644. frotzed mentioned changed the site root to 755, which it should be already. What other plugins are you running?

  18. l0zo
    Member
    Posted 7 years ago #

    Im running akismet,dagon design sitemap generator, diggit, favicon manager, feed list, flickr photo gallery, google sitemaps, optimal title and image manager.

  19. Jonathan Landrum
    Member
    Posted 7 years ago #

    Looks like you got it working, now. What did you change?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags