WordPress.org

Ready to get started?Download WordPress

Forums

Siteground + ModRewrite (15 posts)

  1. blackc2004
    Member
    Posted 7 years ago #

    Hello, has anyone been able to get mod_rewrite working on Siteground? I have had them since April and have tried on and off to get them working. I have asked the Support group there to look into it and they always just point me to the Apache Documentation.

    Here is my htaccess file:
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    Anyhelp would be great! Thanks!

  2. Chris_K
    Member
    Posted 7 years ago #

    They point you to the apache documentation? Does that mean you have access to play with httpd.conf?

    If so, make sure that not only do you have mod_rewrite running, but also have AllowOverride enabled for your blog's directory.

    More trouble-shooting ideas on the Permalinks page in the codex.

  3. blackc2004
    Member
    Posted 7 years ago #

    Sadly, I do not have access to the httpd.conf file. I have tried everything I can on the Codex page, even using the index.php does not work for me. Which it did on my previous host.

    I'm still using WP 2.0.2, but I don't think that should really be causing the problem.

    I did notice that when I try: /%year%/%monthnum%/%day%/%postname%/
    it puts the post number instead of the postname.

  4. blackc2004
    Member
    Posted 7 years ago #

    Hi, Can anyone help me with this? Anyone else using Siteground and able to use mod_rewrite?

    Thanks!

  5. Stefaan Lesage
    Member
    Posted 7 years ago #

    Hi,

    What are you actually trying to do ? Maybe if you could explain what you are trying to achieve, we will be able to point you in the right direction ?

    Regards,

    Annunaki

  6. blackc2004
    Member
    Posted 7 years ago #

    I am trying to get Permalinks working.

  7. SiteGround
    Member
    Posted 7 years ago #

    Dear black2004,

    We have reviewed your case and have found out that there were two lines in your htaccess file that are not needed:

    <IfModule mod_rewrite.c>
    and
    </IfModule>

    We have disabled these two lines and you should no longer experience problems with the mod_rewrite

    Please post a ticket to SiteGround support team if you still experince difficulities.

    Regards,

    SiteGround

  8. moshu
    Member
    Posted 7 years ago #

    Siteground:
    You should have a warning about that on your site - because on the majority of other servers/hosts the default .htaccess file generated by WP, which has those lines, is working.

  9. blackc2004
    Member
    Posted 7 years ago #

    SiteGround: It seems that this is still not working. Can you please double check?

    Also I'd love to post to your support groups, but it seems that the only way to directly e-mail you any more is if the server is down. Can you provide instructions on how to contact you?

    I have also posted in your siteground forums.

    Thanks.

  10. SiteGround
    Member
    Posted 7 years ago #

    You can reach our support team by posting a ticket and here is a detailed explanation how this can be done:

    http://faq.siteground.com/faq/post-ticket.html

    regards,

    SiteGround

  11. blackc2004
    Member
    Posted 7 years ago #

    Thank you. However, can I suggest you create a way to e-mail you about other technical related issues. When I follow that link there is no option to e-mail support. Just to purchase a developer.

  12. blackc2004
    Member
    Posted 7 years ago #

    Here's the latest information from siteground:
    Actually, the issue is caused by the fact that all your WordPress files are in a subdirectory named /wordpress, whereas the blog is being accessed via your domain name only, since the script's index is in your main directory. This makes the WordPress and mod_rewrite recognize the rewrite base as your domain name only instead of cjbonline.org/wordpress, which is resulting in the issue.

    However, mod_rewrite and WordPress permalinks are working just fine on our servers as you can see from the test installation I have performed here:

    http://cjbonline.org/support

    The sample permalink with the default Hello World article is:

    http://cjbonline.org/support/2007/01/23/hello-world/

    If you wish, we can move all your WordPress files in the main directory of your account, which will fix the Permalinks issue. Please advise if this is suitable for you.

    I don't agree with them that moving the wordpress support files to the main directory is going to help. I have it set up in /wordpress/.

    Can anyone else suggest something? I have gone through all the Codex suport files for what is there.

  13. blackc2004
    Member
    Posted 7 years ago #

    Yes, the AllowOverride All option is enabled in the main Apache configuration file. However, the issue comes from the fact that the rewrite base and the actual WordPress files directory differ, when the WordPress files are in a separate directory, which is why the permalinks are not functioning properly. I am afraid that moving your wordpress files in the main directory is the only option for a reliable functioning rewrite engine at the moment.

    Can someone please confirm this response? I have had my wordpress setup with the index.php in the / and all other wordpress files in /wordpress/ before with no issues.

  14. moshu
    Member
    Posted 7 years ago #

    Send them to read this one:
    http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory
    which is proof that the setup you have works on every other host/server.
    (of course, assuming you did follow the steps described in the tutorial)

  15. blackc2004
    Member
    Posted 7 years ago #

    Thanks. I sent them that and here's the reply:

    Well, according to the WordPress documentation, the permalinks should indeed work with your current setup, but it seems that for some reason they are not, even with correctly updated permalinks structure. Alas, there is nothing out of the ordinary with the Apache and more specifically with the mod_rewrite configuration on our servers, which should be causing the issue. I am certain that this comes from the fact that the rewrite base for the rewrite rules adn conditions is different from the actual physical path to your WordPress files. Thus, as I have stated above, I believe that the only available solution at the moment is moving your WordPress files in the main directory.

    As for the register_globals directive - it is set to On.

    So now I'm not sure what to really do....

Topic Closed

This topic has been closed to new replies.

About this Topic