WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
[resolved] site_inaccessible error (16 posts)

  1. CWH Webmaster
    Member
    Posted 1 year ago #

    After upgrading to Jetpack 2.4, I get the following error:

    Error Details: The Jetpack server was unable to communicate with your site http://www.comparewindowshosting.com [IXR -32300: transport error: http_request_failed Operation timed out after 15218 milliseconds with 0 out of -1 bytes received]

    I've checked the forums but couldn't find a suitable solution. It is publicly accessible, and the DNS is working fine. Any help would be greatly appreciated.

    http://wordpress.org/plugins/jetpack/

  2. CWH Webmaster
    Member
    Posted 1 year ago #

    From time to time, I also get this error message:

    Jetpack could not contact WordPress.com: register_http_request_failed. This usually means something is incorrectly configured on your web host.

    Unknown SSL protocol error in connection to jetpack.wordpress.com:443

    I've opened up a support ticket with Godaddy but haven't heard back from them yet. If anyone has any ideas on how to resolve this problem, I would be grateful. Otherwise, as another poster commented, is there a way to get and install version 2.3?

  3. Mothi Venkatesh
    Member
    Posted 1 year ago #

    Me too got a same problem. Shame you Godaddy. "Your website needs to be publicly accessible to use Jetpack: site_inaccessible Error Details: The Jetpack server was unable to communicate with your site http://bloghelpline.com [IXR -32300: transport error: http_request_failed Operation timed out after 15418 milliseconds with 0 out of -1 bytes received]" getting same error :( Help me if you got any answer to this.

  4. esmi
    Forum Moderator
    Posted 1 year ago #

    @CWH Webmaster & @mothivenkatesh: As per the Forum Welcome, please post your own topic. Posting in an existing topic prevents us from being able to track issues by topic. Added to which, your problem - despite any similarity in symptoms - is likely to be completely different.

  5. CWH Webmaster
    Member
    Posted 1 year ago #

    @esmi: I apologize, but I am new on these forums, and I don't see how I've violated any rules as I've posted a follow-up to my own topic that I have created. I'm getting both error messages intermittently when I press Connect to WordPress.com which is why I posted the follow-up to help you, the developers, or anyone else track down the issue. More details about my hosting environment:

    Hosting Provider: GoDaddy
    Environment: Windows
    IIS Version: 7.0
    PHP Version: 5.3

    So far the response from GoDaddy support is unsatisfactory. They suggested I downgrade to PHP version 5.2 or run the latest JetPack version... I have another WordPress installation running on another Windows hosting environment with JetPack 2.4 installed on top of PHP 5.3 that works fine.

  6. esmi
    Forum Moderator
    Posted 1 year ago #

    @CWH Webmaster: My profound apologies. I hadn't noticed that you started this topic. :-0

  7. Richard Archambault
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Hi all!

    This timeout error indicates that your site currently blocks all incoming connections from WordPress.com. I noticed that your site is hosted with GoDaddy, on a shared Windows server. In the past few weeks, other GoDaddy users reported similar issues; they were also hosted on a Windows server.

    GoDaddy is aware of the issue, and recommends to all users experiencing issues with their Windows servers to switch to a Linux server instead. To do so, go to your site management panel, and try the following:

    1) Click the + next to the hosting
    2) Clicked on options, then the customize tab
    3) Select the drop down menu under “Plan” and scroll up to select Linux

    According to GoDaddy, it can take up to 48 hours for the changes to apply, but your site will be completely transferred, and you will then be able to use Jetpack.

    If you do not feel comfortable making the change by yourself, do not hesitate to contact GoDaddy to let them know about the issue.

  8. CWH Webmaster
    Member
    Posted 1 year ago #

    Hi Richard,

    Thank you for your response. That's pretty much what GoDaddy told me as well. I'm a little disheartened by the response because that option is not available if you're on their Economy (free) plan. At least I don't see it according to instructions provided. So my only options now are to try to downgrade to JetPack 2.3 or below which worked before or move the site to another hosting provider which works. I have WordPress with JetPack 2.4.2 (latest) installed on another Windows shared hosting provider with PHP 5.3, and I don't have any problems there. I'm just wondering if there is some weird network firewall rule that is preventing my site (and others) from connecting to WordPress.com on port 443 which is causing the problem. Again, thanks for your help.

  9. Richard Archambault
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    To be honest, we do not yet know what it is on GoDaddy's side that is causing this issue. We are in communication with them but have not come to a conclusion yet. I understand your frustration though, and wish I could tell you something more conclusive.

  10. Traveltechnos
    Member
    Posted 1 year ago #


  11. CWH Webmaster
    Member
    Posted 1 year ago #

    I just wanted to provide an update to those who may still be struggling with this issue. GoDaddy finally gave me a solution which seems to have resolved the problem:

    1) Update to JetPack 2.4.2 (latest version).
    2) Downgrade to PHP 5.2 if you were running PHP 5.3.
    3) Recycle the application pool.

    I don't have any other PHP applications running except for WordPress, and the version of WordPress I'm running is 3.6. This is an acceptable solution, and my hats off to the GoDaddy support staff for going the extra mile to help me find a suitable workaround.

  12. CWH Webmaster
    Member
    Posted 1 year ago #

    I just wanted to add this follow-up which may/may not be related to the problem. I had to perform some reorganization of my website last night and decided to change the "WordPress" portion of it because I wanted to host it in a sub-domain. I noticed some changes to my configuration files because I backup my site regularly:

    1) A phpinfo.php file was uploaded. I'm not sure if I did that or GoDaddy while troubleshooting, so I removed it.
    2) Caching elements within the web.config file were removed.
    3) php.ini file had Wincache enabled. It was renamed to php.ini.bak

    So the problem may have been relating to caching and how GoDaddy has their Windows hosting environment configured.

  13. Richard Archambault
    Happiness Engineer
    Plugin Author

    Posted 12 months ago #

    Thanks CWH for the info!

  14. techtangerine
    Member
    Posted 10 months ago #

    I can confirm that this problem is happening on GoDaddy hosting with Windows Servers. I can't use the workaround because my plan limits my options. I am hoping that the plugin is updated by the author. Until then no jetpack for me.

  15. techtangerine
    Member
    Posted 10 months ago #

    Update: The issue seems to have mysteriously fixed itself as of now. I am able to register and use Jetpack.

  16. Richard Archambault
    Happiness Engineer
    Plugin Author

    Posted 10 months ago #

    @ techtangerine: out of curiosity, what is your site's URL?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic