WordPress.org

Ready to get started?Download WordPress

Forums

site url not working as it should. (6 posts)

  1. dvalin
    Member
    Posted 2 years ago #

    god for anyone watching this forum I must be a joke. Iv been running wordpress without fail for a while, then a month ago slow admin hit me after that its just been one nightmare after another.

    I now have wordpress with multi site back up and running admin is fine and I have fixed almost all of my other issues.

    HOWEVER..

    My Current problem is that http://cruel-gaming.com does not work, http://www.cruel-gaming.com does.

    A Records are fine, iv not changed them since my last install which worked fine so something changed during this new fresh install.

    I tried changing the database to point siteurl and home to http://cruel-gaming.com but that didnt work either it.

    http://cruel-gaming.com either fails to redirect or load, or it spawns a create new blog called cruel-gaming.com.cruel-gaming.com page lol.

    Any help here would be appreciated as im lost for ideas.

  2. Jesper van Engelen
    Member
    Posted 2 years ago #

    Are you sure this isn't a .htaccess problem? Have you installed any plugin that might be causing this?

    I'm getting a recursive redirect (redirect loop): the page is redirecting to a page which redirects to itself, and so forth.

  3. dvalin
    Member
    Posted 2 years ago #

    here is my .htaccess in /

    # Switch rewrite engine off in case this was installed under HostPay.
    RewriteEngine Off
    
    SetEnv DEFAULT_PHP_VERSION 5
    
    DirectoryIndex index.cgi index.php
    
    redirect cruel-gaming.com http://www.cruel-gaming.com
    
    # BEGIN WordPress
    #<IfModule mod_rewrite.c>
    #RewriteEngine On
    #RewriteBase /
    #RewriteRule ^index\.php$ - [L]
    #RewriteCond %{REQUEST_FILENAME} !-f
    #RewriteCond %{REQUEST_FILENAME} !-d
    #RewriteRule . /index.php [L]
    #</IfModule>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(wp-(content|admin|includes).*) $1 [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]
    # END WordPress

    Im running wordpress installed in / and I have multisite on with another two blogs one in dev.cruel-gaming.com and one in swtor.cruel-gaming.com

    http://cruel-gaming.com and http://www.cruel-gaming.com should both point to / my web root..

    Anyway hope that .htaccess file shows something odd cos I don't think its a plugin.

  4. dvalin
    Member
    Posted 2 years ago #

    oh you will see I tried a redirect but that didnt work.

  5. Jesper van Engelen
    Member
    Posted 2 years ago #

    Try this, it should work:

    RewriteEngine On
    RewriteCond %{HTTP_HOST} !^www\.
    RewriteRule ^(.*)$ http://www.%{HTTP_HOST}/$1 [R=301,L]

    Make sure to enable the rewriting engine (first line in the code above).

  6. dvalin
    Member
    Posted 2 years ago #

    Ah yeah that works, just one thing.

    going to http://cruel-gaming.com works a treat now.
    but
    http://something.cruel-gaming.com redirects to the blog sign up but it passes http://www.something instead of something if you know what I mean.

    I dont actually have blog sign ups on at the moment but was planning to turn them back on once i had all this mess sorted out.

    oh and thanks btw.

Topic Closed

This topic has been closed to new replies.

About this Topic