WordPress.org

Ready to get started?Download WordPress

Forums

Site URL Not Working (8 posts)

  1. Gemfruit
    Member
    Posted 1 year ago #

    I have a brand new site, with the wordpress folder at mysite.com/wordpress. I changed the Site URL field to mysite.com, while leaving the wordpress field at mysite.com/wordpress. I've done this hundreds of times, but for whatever reason, it's not working in the latest version of wordpress. The field is changed, but the url mysite.com keeps bringing up the directory, and mysite.com/wordpress is displaying the site.

    I have fresh installed this website / db 2 times now, with no luck. The website directory is 100% empty aside from an empty cgi bin folder, and the wordpress folder. It is completely barebones, and I've done / am doing this on many sites. This is clearly a bug in the latest wordpress, and I'd love to have it fixed / know how I can fix this issue.

  2. Gemfruit
    Member
    Posted 1 year ago #

    I got buried on page 3 of the forums, and still need help with this. Any ideas?

  3. Krishna
    Volunteer Moderator
    Posted 1 year ago #

    Please review:
    http://codex.wordpress.org/Changing_The_Site_URL
    http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory

    Can you link to your site so that someone will have a look at it and understand what the actual setting in your site is.

  4. Andrew
    Forum Moderator
    Posted 1 year ago #

    I got buried on page 3 of the forums

    You need to be fair, everyone else is in the same position as you. Don't bump.

    Bumping or replying to your own thread also removes you from the No Replies list, which some forum volunteers prioritise over other threads.

  5. Gemfruit
    Member
    Posted 1 year ago #

    http://www.anightonburlington.com

    As I said, I've done this a hundred times. It's a new install, I'm not changing the directory of an existing site (which I also know how to do). I put the wordpress folder inside public_html/anightonburlington.com, ran the install, and attempted to change the site url via the Settings tab in WordPress. NORMALLY this happens,

    If you already have WordPress installed in its own folder (e.g., http://example.com/wordpress), then the steps are as follows:

    Go to the General panel.
    In the box for Site address (URL): change the address to the root directory's URL. Example: http://example.com
    Click Save Changes. (Do not worry about the error message and do not try to see your blog at this point! You will probably get a message about file not found.)

    This is not happening for me, which it always has before. It says settings save, and the site continues on as if I never changed anything.

    Right now (fresh install again, as of 5 minutes ago), all that has been altered is the Settings, like so.

    WordPress Address (URL) - http://www.anightinburlington.com/wordpress
    Site Address (URL) - http://www.anightinburlington.com

    I've also tried swapping those, thinking I was going crazy (despite comparing the setup to my other sites), and it just broke everything.

    As for bumping, I made the mistake of posting at 1AM last night (12 hours ago), and the forums were completely empty. I went 12 hours without a response, and instantly got 2 responses upon bumping.

  6. Gemfruit
    Member
    Posted 1 year ago #

    SOLVED

    I was thrown off by the lack of an error when changing that field, and forgot that I needed to move the index.php file and make that one line alter to the includes file. (require('./wordpress/wp-blog-header.php');) Still odd that the error doesn't happen any more, but no biggie.

  7. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    Your site is visible at http://www.anightinburlington.com

    Is that not what you want?

    EDIT - cross-posted.

  8. Krishna
    Volunteer Moderator
    Posted 1 year ago #

    This is currently your home URL: http://www.anightinburlington.com
    and your Site URL (where your WordPress core files reside):
    http://www.anightinburlington.com/wordpress

    EDIT: Looks like this is another cross-post!

Topic Closed

This topic has been closed to new replies.

About this Topic