WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
Site Title Added to Page Header Titles (7 posts)

  1. wpcdn
    Member
    Posted 1 year ago #

    WordPress version: 3.5.1
    WordPress SEO version: 1.4.7

    I did this: Installed the plugin on a site. The site displays page titles on each page (on the page itself, not the browser window title). So, for example, the title on the "About Us" page would be "About Us" (as expected).

    I expected the plugin to do this: I did NOT expect it to modify these page titles.

    Instead it did this: It modified these titles. So, for example, instead of "About Us" we have "About Us - Website Name". That's fine for the browser window title, but not for this title.

    This problem also seems to affect the breadcrumbs title in some cases.

    Please help! Thanks.

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. wpcdn
    Member
    Posted 1 year ago #

    Clarify...I mean the site DOES show the normal browser window titles, but these are not the ones I'm talking about.

  3. Hassan
    Member
    Posted 1 year ago #

    That's probably an issue with your theme.
    What theme are you using? Can you see if there's a code the_title(); inside the header.php or page.php files of your theme?

  4. Iris17
    Member
    Posted 1 year ago #

    I have almost the same problem. it says for the homepage: websitename/titelofpage/websitename.

    for the pages it says: titelofpage/websitename websitenaam (twice).

    How to change this?

    thanks in advance

  5. Hassan
    Member
    Posted 1 year ago #

    @Iris17, go to SEO > Titles & Metas > Post Types and see if the Title template field for Pages contain this tag: %%sitename%%

    Try deleting it and see if that works for you.

  6. Iris17
    Member
    Posted 1 year ago #

    hi Hassan,

    at least it took some things out....
    but, please check my site (skmc.eu). On some pages I did the seo-check and then you get: marketingskmc. One word. The homepage has skmc directly next to the description.

    What I would like:
    homepage as it is but without the 2nd SKMC
    other pages: SKMC | marketing, SKMC | over ons. Etc.

    What to fill in where? (or is there a instruction somewhere? preferably in dutch...).

    thanks

  7. Hassan
    Member
    Posted 1 year ago #

    @Iris17

    1) Please make sure you set the option "Force rewrite titles" to checked. It's under SEO > Titles & Metas > General

    2) Can you copy/paste here the values inside your Title template field for Pages (same one you modified in the last post)?

    3) Looks like you have a static page as your home page. You can determine how the title of the home page appears by editing the home page itself. Follow the link from SEO > Titles & Metas > Home which says: "editing the front page itself ยป"

    Let me know if that works.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.