WordPress.org

Ready to get started?Download WordPress

Forums

BulletProof Security
[resolved] Site stop working after upgrade .47.6 (14 posts)

  1. docora
    Member
    Posted 1 year ago #

    Hi,

    My site blog stops working after upgrading to .47.6. When I resave Permalink Settings then it starts working now but BPS gave me error of "BPS Alert! Your site does not appear to be protected by BulletProof Security". Due to this reason I tried to activate BPS plugin and again my site stops working. Present I resave Permalink Settings and running site with "BPS Alert! Your site does not appear to be protected by BulletProof Security". Kindly suggest. My site link is

    [ Moderator note: <li> removed ]

    http://www.giteshtrivedi.com/blog
    http://wordpress.org/extend/plugins/bulletproof-security/

  2. Viscosity
    Member
    Posted 1 year ago #

    I got the same error and in the end i have deleted it from my backup otherwise i am in deep trouble.

  3. AITpro
    Member
    Plugin Author

    Posted 1 year ago #

    1. Deactivate all of your plugins except for BPS.
    2. Click the AutoMagic buttons
    3. Activate BulletProof Mode for your Root folder.
    4. Lock your Root .htaccess (if your Host allows this)
    5. Activate all of your plugins again.

  4. AITpro
    Member
    Plugin Author

    Posted 1 year ago #

    I checked the modlook appropriate uses list and found that "- a post full of code" is kind of close to the issue in this thread, but this actual issue is some kind of code entered in the previous post caused the page to be displayed "funky". ;)

  5. AITpro
    Member
    Plugin Author

    Posted 1 year ago #

    @docora - What does "My site blog stops working after upgrading to .47.6" mean exactly?

    Please state the exact details of what is not "working" and any error messages that you see. Thanks.

  6. docora
    Member
    Posted 1 year ago #

    After upgrading to .47.6, all pages disappeared and didn't show. Even category pages are not working. All were blank.

    After that, I re-saved Permalink Settings and everything worked nicely and in WP admin portal I got error "BPS Alert! Your site does not appear to be protected by BulletProof Security". I tried to refresh page but error persisted and due to this reason, again I enabled BulletProof Mode and again found site was not working and all pages disappeared.

    Due to this reason, again I re-saved Permalink Settings and now everything is working fine but my WP security plugin is showing that I am using .47.5 (even though upgraded to .47.6). What to do?

  7. AITpro
    Member
    Plugin Author

    Posted 1 year ago #

    Sounds like the something is blocking you/BPS from updating the root .htaccess file. Try this.

    1. Click the AutoMagic buttons
    2. Go to the Edit/Upload/Download page
    3. Copy the secure.htaccess file contents to the "Your Current Root htaccess File" tab window and save your changes.

    Is the file actually updated? Do you see that the your root .htaccess file has the new .htaccess code in it?

  8. docora
    Member
    Posted 1 year ago #

    Hi,

    Yes. File updated properly as per your given trick. But after that again site stops working. For making working condition I had to save Permalink Settings and found site is now working. Issue persists.

  9. AITpro
    Member
    Plugin Author

    Posted 1 year ago #

    Do have cPanel or some other type of Host Control Panel? The issue/problem you are describing sounds like the broken cPanel HotLink Protection Tool problem >>> http://wordpress.org/support/topic/plugin-bulletproof-security-broken-cpanel-hotlink-tool-404-errors-unable-to-edit-htaccess-files?replies=9

  10. AITpro
    Member
    Plugin Author

    Posted 1 year ago #

    Yep i just checked and your Host is HostDime and they do use cPanel so most likely this is the problem. Here are some screenshots of the problem >>> http://forum.ait-pro.com/forums/topic/read-me-first-free/#cpanel-hotlink-protection

  11. docora
    Member
    Posted 1 year ago #

    Dear friend,

    My all blogs are containing same configuration of hotlink protection tool and I am using your plugin from last 1 year. Everytime I am upgrading your plugin but never got any issue. Only this time I got issue in one site and due to this reason, I didn't upgrade your plugin from my every sites. Are you confirm root cause of this issue would be only hotlink protection tool?

  12. AITpro
    Member
    Plugin Author

    Posted 1 year ago #

    Actually i need for you to confirm this. The broken cPanel HotLink Protection Tool problem has been occurring for over 10 years. I am currently working on a custom script that will hopefully allow BPS to disable this broken cPanel tool so that it does not continue to break BPS, WordPress and your website.

    NOTE: The broken cPanel HotLink Protection Tool problem can and will happen randomly or without any logical reason - the tool is completely broken and also Enable and Disable are also broken - you cannot turn this broken Tool off.

    To confirm that this is the problem that is occurring on your website please see this BulletProof Security Forum Topic link below. It shows screenshots of the problem and also provides a solution. NOTE: This problem will continue to occur forever or until i create/complete the custom script that i am working on that will hopefully permanently disable the broken cPanel HotLink Protection Tool.

    http://forum.ait-pro.com/forums/topic/read-me-first-free/#cpanel-hotlink-protection

  13. AITpro
    Member
    Plugin Author

    Posted 1 year ago #

    Was the problem being caused by the broken HotLink Protection Tool? If so, and the problem is resolved then please resolve this thread. Thank you.

  14. AITpro
    Member
    Plugin Author

    Posted 1 year ago #

    Resolving due to lack of response. If the problem is still occurring please unresolve this thread. Thank you.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.