WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
[resolved] Site seems slower after install of W3 total cache (8 posts)

  1. Susan
    Member
    Posted 3 years ago #

    I've had to de activate the plugin as my site seemed much slower with this plugin. I followed yoast's settings for his install, including not using database caching as I only have disk available. Is there something else I might have been doing wrong? Page load time went up as high as 40 seconds.

    Thanks

  2. tgeorge
    Member
    Posted 3 years ago #

    @shoesie
    If you go here :

    Google Page Speed
    http://pagespeed.googlelabs.com/

    and enter the address of your site, "Google Page Speed" will try to identify the causes of your speed problem. If it fails to identify them, try disabling your plug-ins one by one, to see if your speed problem is not caused by a faulty plug-in.

  3. Susan
    Member
    Posted 3 years ago #

    Thanks @tgeorge

    http://pagespeed.googlelabs.com doesn't show anything unusual.

    I tried disabling all my plugins, but the only thing that makes the page load normally is if I disabled W3 Total Cache.

  4. chensihai
    Member
    Posted 3 years ago #

    What is the Cache Method of Page/Database/Object you used?

    It's default to Disk, but that's not good performance.
    \
    If you used APC, please make sure it is enough size.

  5. Susan
    Member
    Posted 3 years ago #

    page: disk (enhanced) - this was the only option not greyed out
    minify: disk, jsMin
    database: NOT enabled
    object: NOT enabled
    browser cache: Enabled

  6. gooma2
    Member
    Posted 3 years ago #

    with this plugin, you've got to take it slow when you're tweaking. I've busted my site a few times doing too many tweaks at once.

    it's a pain in the butt, but if you're seeing a slowdown on your site, you can even check out http://gtmetrix.com which gives a very detailed breakdown on what's causing the issues and exactly which scripts/files are doing it so you can go back and do more tweaking.

    biggest advice is that you do the tweaks in preview mode and refresh your site after each change so you can see how it gets affected.

    at one point I had set my stylesheet to be minified but that really slowed my site down, but it might word for yours. each template is so different so it takes some experimenting, but if you can get into a 'compulsive obsessive' mode for an afternoon, it's pay off.

  7. Frederick Townes
    Member
    Plugin Author

    Posted 3 years ago #

    There's some good advice here, if you're still having trouble, please submit a bug submission form from the support tab of the plugin.

  8. Susan
    Member
    Posted 2 years ago #

    Thanks for all the help guys.
    I played around with the settings/plugin conflicts and the plugin is now working fine.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic