WordPress.org

Ready to get started?Download WordPress

Forums

Site running SUPER slow (5 posts)

  1. chazzrockwell
    Member
    Posted 2 years ago #

    I've been running my website, http://www.chazzrockwell.com for a while. Things used to load very quickly, but for the last several months my site has been loading extremely slow. I'm not entirely sure when this began, but I assure you it was not always the case. I've got several plugins installed (lightbox, akismet, google xml, jetpack, ect...) and when they are all enabled my website REALLY slows to a crawl. At the moment they are all disabled and even still, pages load super slow. I just got off the phone with GoDaddy and they assured me that everything is in order with my hosting and the problem is on the wordpress side of things. So here's where I'm at...

    - Version 3.3.1
    - Graveyard Shift 0.2 Theme
    - All plugins disabled
    - GoDaddy assures me that their are no hosting problems
    - Slow load times (my network and internet are not the problem)
    - tools.pingdom.com shows that my site is slower than 77% of tested websites (97% when plugins are running)

    Any help or tips on where to go from here would be super appreciated. Please help! Thank you!

  2. kmessinger
    Volunteer Moderator
    Posted 2 years ago #

    http://tools.pingdom.com/fpt/#!/B2wWLiNt7/http://chazzrockwell.com/

  3. Hudsonave
    Member
    Posted 2 years ago #

    Hi Chazzrockwell,

    I am searching the forums myself for some support with a particular WordPress theme we are running. I have had some success though, and pending today's results may have resolved the issue.

    The first place I would suggest looking to help speed your site up would be the downloading the Quick Cache plugin. This can help your site run a good deal better. Don't worry about the specific functions, just activate it.

    You may see a good jump in performance.

    Also,you'll want to ensure that all of your images are optimized outside of WordPress. Do not rely on WordPress to manage your images because it will not give you the same size quality like you would get from using Adobe Photoshop or GIMP.

    Additionally, you'll want to ensure that you use as little CSS inside of your posts as possible. Leave that to a custom web sheet.

    Hopefully this information is useful!

  4. Pioneer Valley Web Design
    Member
    Posted 2 years ago #

    It's all of the players and embedded videos, try changing the settings at Admin Dashboard>Settings>Reading>Blog pages show at most>Set to a lower number like 2 or 3

    I would also look for a better plugin for the 'player' and you can reduce the initial size of images and the YouTube embeds.

    Additionally, it appears that compression is not enabled on your site. Review that with your host.

  5. c-bass
    Member
    Posted 2 years ago #

    it is wordpress itself with version 3.3.1, see http://core.trac.wordpress.org/ticket/18536

Topic Closed

This topic has been closed to new replies.

About this Topic