WordPress.org

Ready to get started?Download WordPress

Forums

site requires login for public to view (5 posts)

  1. cpneill
    Member
    Posted 4 years ago #

    Hi there, I just set up my site a few days ago and noticed that when I type in my site's address, http://www.lifeinvagabondia.com as if I'm some person out there going to look at my site, a box drops down asking for username and password. When I type in my information, it goes to the site, but obviously I don't want the public to have to type a username and password.

    after I log in once, it lets me go straight to the site agin and again, until I close out my browser, then reopen, and it asks for the login info again.

    I've searched the forums but haven't found an answer, at least not one that I understand. Most people have the opposite problem, wanting to make their site password protected. I've read something about editing .htaccess file, but am not sure if that's what I need to do (or what edits to make)

    In my admin panel under settings->privacy settings I have marked "I would like my blog to be visible to everyone, including search engines (like Google, Bing, Technorati) and archivers"

    I called GoDaddy to see if it was some server setting or something, and they just said it's a wordpress setting having something to do with permissions and told me to google an answer. I've had no luck.

    The login box appeared for the GoDaddy help guy, and I called my friend and asked him to go to my site address and the login box appeared for him too.

    Please help! I want people to be able to see my site without needing a username and password!

  2. meh1965
    Member
    Posted 4 years ago #

    Could it be your public_html directory is password protected?

  3. cpneill
    Member
    Posted 4 years ago #

    I don't know. What would I need to do to fix that? Sorry, but I'm a dummy when it comes to all this stuff.

    By the way, here's the message Safari gives me on the login box if it helps:
    "To view this page, you must log in to this area on http://www.lifeinvagabondia.com.:80:
    User Backups
    Your password will be sent unencrypted."

    Thank you for the response!

  4. Saildude
    Member
    Posted 4 years ago #

    I just clicked on your link at the top and I was not ask for a password. Firefox 3.6 - A posting on Tibet and some video -

  5. cpneill
    Member
    Posted 4 years ago #

    yeah, I think I just fixed it right after I posted that. I opened the .htaccess file in Text Edit and just looked at what was there. The 4th line down said "require valid-user" I just deleted that line and saved the file and uploaded it back into my root folder, deleting the old .htaccess file. And now it doesn't ask for a password.

    Thanks for your help!

Topic Closed

This topic has been closed to new replies.

About this Topic