WordPress.org

Ready to get started?Download WordPress

Forums

Site pagination leads to Error 404 (7 posts)

  1. Romanowitsch
    Member
    Posted 3 years ago #

    Hey WPers,

    I'm about to customize the Platform theme framework for my blog. Almost everything's working just fine.

    But since I installed Platform, my site pagination ("Previous Entries") always leads to the famous

    Error 404: NOT FOUND!Your browser cannot find the document corresponding to the URL you typed in.

    Here's a link to my Blog: grapholution.net

    Besides that, a child-site I created in the backend, can't be modified anymore. When I click on "Edit page" the URL changes correctly to

    http://grapholution.net/wp-admin/post.php?post=365&action=edit

    but the site stays empty... no admin options, nothing.

    Can someone help me out with these two (or at least one of the) problems?

    Romanowitsch

  2. Gisha James
    Member
    Posted 3 years ago #

  3. Romanowitsch
    Member
    Posted 3 years ago #

    Hey Gisha,

    I've read it and there might be 2 possible answers. Either my SEO URL settings or the synchronisation of total page numbers in admin-settings and theme-settings.

    I'm going to try this later.

    Thank you so far for posting this!

    R

  4. Romanowitsch
    Member
    Posted 3 years ago #

    Hm,

    I first to match the WP pagination settings with the settings of my theme, but my theme doesn't define the posts per page. Instead it's got a
    get_option('posts_per_page')-demand.

    So, that's not the problem.

    Then I reset my permalinks and this is it! If I chose the (ugly looking) default permas then the pagination works just fine.

    But I want them to look like this

    http://www.example-blog.net/categorie/post-title

    How can I do this?

  5. jocken
    Member
    Posted 3 years ago #

    have you checked permalinks and reading? There could also be so that your server haven't enabled mod_rewrite.

  6. Romanowitsch
    Member
    Posted 3 years ago #

    hey jocken,

    I've checked the permalinks. And if I set them to WordPress standard (those ugly looking example.net/?p=10008 then the pagination works.

    But I don't want them like that.

    I've checked my server and definitely supports the mod_rewrite module.

    Now, my .htaccess looked always like this:

    AddType x-mapp-php5 .php
    AddHandler x-mapp-php5 .php
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    On my server's help page, they wrote, I should enter in the .htaccess the following code:

    RewriteEngine on
    RewriteCond %{REQUEST_URI} user/(.*)$
    RewriteRule user/(.*)$ /user.php?id=$1

    So I did and now my .htaccess looks like this:

    AddType x-mapp-php5 .php
    AddHandler x-mapp-php5 .php
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine on
    RewriteCond %{REQUEST_URI} user/(.*)$
    RewriteRule user/(.*)$ /user.php?id=$1
    </IfModule>
    
    # END WordPress

    But it still doesn't work.

    What's wrong?

  7. Romanowitsch
    Member
    Posted 3 years ago #

    Can anybody help me out?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags