WordPress.org

Ready to get started?Download WordPress

Forums

Site only shows Index of/ directory (13 posts)

  1. Rachel713
    Member
    Posted 5 years ago #

    I've upgraded from 2.6.5 to 2.7. When I click the "Visit Site" link, it takes me to the Index of/ directory. Even when I click on index.php, it only brings me back to the main directory.

    I tried doing a brand new installation of 2.7, thinking I may have messed up during the upgrade, but the same thing happened. I'm not using any custom themes or plugins.

    Funny thing is, everything works fine when I upload it online, it's just when I try to edit offline with Apache it doesn't work.

    Does anyone know what's wrong and how I can fix it?

  2. ldexterldesign
    Member
    Posted 5 years ago #

    Yep, just installed a fresh WP 2.7. Got exactly the same problem.

    Everything is functioning fine, but the moment I click from the back-end/CMS through to the blog, using the 'Visit site' link in the top left, I just get presented with a directory index.

    File structure for reference:
    Root > WordPress > all the files...

    Images
    - http://tinyurl.com/7qyn69
    - http://tinyurl.com/89kq63

    Any thoughts. The last time I worked on a WP site I had big issues with working locally, mainly regarding displaying comments. Now this... it's really putting me off working on WP sites locally.

    Cheers,
    Lewis

  3. ldexterldesign
    Member
    Posted 5 years ago #

    One more thing for reference;

    http://localhost/wordpress/wp-admin/ - takes me to a directory index, until I type in 'index.php' at the end of the URL and THEN I get my back-end/control panel up.

    I would have thought tagging the same, 'index.php', onto the end of http://localhost/wordpress/ would do the same, but it doesn't.

    Help would be ace! I'm seeing stuff relating to a 'htaccess' file come up in the these forums, and location of the files, but It shouldn't be this complicated.

    Cheers,
    L

  4. ldexterldesign
    Member
    Posted 5 years ago #

    OK, this is weird, because I've just reverted to installing WP 2.6 in exactly the same way and everything works as it should.

    My guess is I haven't got something installed/enabled that WP 2.7 needs. Is anyone more clued-up on the inner workings of what's going on here. Is there a possibility I haven't got a PHP extension installed which I need?

    PHP extentions installed so far:
    - MySQL
    - MySQLi
    - Mcrypt

    I'm running the latest Apache, PHP, phpMyAdmin.

    At this point I'm gonna have to go with WP 2.6 - seen as it works and 2.7 doesn't. I've just spent the best part of a day messing around with this now :[

    Cheers,
    L

  5. ldexterldesign
    Member
    Posted 5 years ago #

    *Bump*

    This has got to be a 2.7 issue, or the install procedure needs a review. Has anyone else installed 2.7 locally without hitch? Now that would put my mind at rest.

    L

  6. iridiax
    Member
    Posted 5 years ago #

  7. ldexterldesign
    Member
    Posted 5 years ago #

    Thanks, yea, I saw that page. I'm guessing by the conciseness of your response that you've never had a problem installing WP locally - I envy you if that's the case.

    I installed/configured WP on top of separate Apache/PHP/MySQL installs, so yea, next time I'll try using an 'all-in-one-install' Server Suite or XAMPP package.

    Cheers,
    L

  8. missionbells
    Member
    Posted 5 years ago #

    I had the same problem. I solved it by uploading a .htaccess file into the root of the blog. This is the code:

    DirectoryIndex index.php index.html
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress
  9. asianvato
    Member
    Posted 5 years ago #

    I was having this issue locally. I added the .htaccess but I was still getting the "index of" page. I figured out in the httpd.conf of Apache if you change AllowOverrride from None to All it will work.

    I hope this helps someone. I was getting very frustrated.

    Joe

  10. salmankhan99
    Member
    Posted 5 years ago #

    Hi guys, has anybody managed to sort this problem out? i have tried both the method suggested by missionbells and asianvato. but unfortunetly i still have the same problem? somebody please help, i am on the verge of giving up

  11. graystone
    Member
    Posted 5 years ago #

    See the topic 'WordPress Local Installation Problem'
    The solution posted there solved this problem for me.

    You may need to add index.htm and index.php to the DirectoryIndex line in your Apache httpd.conf file.

  12. asianvato
    Member
    Posted 4 years ago #

    I came across this issue again while transferring a site to a new domain. To fix this I uploaded the WordPress files again. I think there was probably a corrupt file.

    Hope this helps someone.

  13. sproell
    Member
    Posted 4 years ago #

    I was having the same problem and I simply changed this section in my httpd.conf file:


    #
    # DirectoryIndex: sets the file that Apache will serve if a directory
    # is requested.
    #
    <IfModule dir_module>
    DirectoryIndex index.html index.php
    </IfModule>

    I added the index.php to the end and everything works.

Topic Closed

This topic has been closed to new replies.

About this Topic