WordPress.org

Ready to get started?Download WordPress

Forums

Site not functioning properly in IE and Opera, please help! (14 posts)

  1. spencerteeter
    Member
    Posted 3 years ago #

    my site works fine with everything except IE and Opera. In Opera it briefly shows the default header for my theme before my header appears, and it does that every time I go to a new page or a different tab. I have also had another user message me saying they couldn't view my site properly in Opera.

    In IE my nave bar runs into a second row of tabs, but it is only supposed to be one, the last tab jumps down to a second row on my HOME PAGE ONLY

    Please help me with this!

    my site is http://www.spencerteeter.com

  2. Tara
    Member
    Posted 3 years ago #

    start with sorting out the markup errors.

  3. spencerteeter
    Member
    Posted 3 years ago #

    im not sure how to fix those...most of them i dont understand the problem.. any help?? is there an auto fix?

  4. Joseph
    Member
    Posted 3 years ago #

    Your nav bar issue occurs in every browser, not just IE. You have 1px padding on the right side of each tab only on your home page which increases the total width thus pushing down the last tab into the next row.

  5. spencerteeter
    Member
    Posted 3 years ago #

    ohh, do you know where i can change that? is it style.css and what part of so?

  6. Joseph
    Member
    Posted 3 years ago #

    Find ul.navigation li { ... } in your style.css file and remove padding: 0 1px 0 0;

    For your header issue, remove #page{background:transparent url(images/header.jpg) no-repeat center top;} from /mystique/style.css

  7. spencerteeter
    Member
    Posted 3 years ago #

    i removed the padding: 0 1px 0 0; and it still has the padding but now it also had a padding underneath.. i havent tried the header yet..

  8. Joseph
    Member
    Posted 3 years ago #

    My mistake. Change that to padding: 0; instead of removing it.

  9. spencerteeter
    Member
    Posted 3 years ago #

    that got rid of the one underneath, but the padding is still beside each tab

  10. Joseph
    Member
    Posted 3 years ago #

    You mean the black vertical lines? That's a background image and to remove it, remove background:transparent url(images/nav-div.png) no-repeat right top;.

  11. spencerteeter
    Member
    Posted 3 years ago #

    ohh i see, i thought that was still padding since they only show up on the home tab. Thank you very much for your help. As far as the header. It stopped the default mystique header from showing up, but i am getting a plain black header show up briefly before mine does (in Opera) also in Opera I noticed my "favicon" beside my url is distorted, also some of my sidebar widgets are acting up (mainly teh facebook one, when i scroll down over it on my laptop it runs off the page into a plain white box...any suggestions?

  12. Joseph
    Member
    Posted 3 years ago #

    Regarding the header. What was happening before was that the default header is loaded first with the first style sheet then you overwrite that with a second style sheet. Now that the header in the first style sheet is removed, your header will not appear until the second sheet is loaded. If you don't like that then you can add body{background-image:url("http://www.spencerteeter.com/wp-content/uploads/8787.jpg");background-repeat:no-repeat;background-position:center top;} to /mystique/style.css.

    The distorted favicon would be an image issue so I can't help you with that and I don't know a fix for the facebook issue either.

  13. spencerteeter
    Member
    Posted 3 years ago #

    ok no problem, and thanks so much..the header thing i can live with, i just didnt want the default one coming up but thats gone so its all good...

    one more thing maybe you know how to do...I want to make it so when i hover over a tab on my nav bar it highlights to the same color it would if i were on that page. like when im on my home page the home tab is highlighted darker, i want that to happen when i hover over each tab...do you know how to do that?

    oh and also i just noticed, my nav bar has a light grey line near the bottom, it almost looks dotted, i dont remember it being there..any idea on how to get rid of it as well?

  14. spencerteeter
    Member
    Posted 3 years ago #

    any ideas?

Topic Closed

This topic has been closed to new replies.

About this Topic