WordPress.org

Ready to get started?Download WordPress

Forums

Site Move problem (15 posts)

  1. mmarkham
    Member
    Posted 8 years ago #

    Hey everyone. I could use some advice here. I just moved servers for my 2.0 installation. I followed the usual steps--I backed up the database and restored that on the new server, and I backed up the entire webroot directory and restored that on the new server. I didn't change domain names at all, just servers. So now when I try to go the new server, it shows me this error:It doesn't look like you've installed WP yet. Try running install.php. Just for fun, I clicked on it, and it came back with:You appear to have already installed WordPress. To reinstall please clear your old database tables first.

    I'm baffled. Any ideas?

    Matt

  2. Mark (podz)
    Support Maven
    Posted 8 years ago #

    Have you deleted the cache ?
    /wp-content/cache

  3. mmarkham
    Member
    Posted 8 years ago #

    Yes, the cache is gone.

  4. Mark (podz)
    Support Maven
    Posted 8 years ago #

    There's no dns changes involved ?
    No local caching that could possibly be happening ?

  5. mmarkham
    Member
    Posted 8 years ago #

    No, the DNS issues that potentially existed are gone. I made the switch a week ago from one ISP to another.

  6. mmarkham
    Member
    Posted 8 years ago #

    Anyone else got any ideas?

  7. splosh
    Member
    Posted 8 years ago #

    What if you clear the database, click install, then
    re populate the database?

  8. Mark (podz)
    Support Maven
    Posted 8 years ago #

    splosh - that would delete the blog.

    I'll ask on hackers

  9. splosh
    Member
    Posted 8 years ago #

    I cant get my head around that!
    what about the hosting account user name, then?

  10. wantmoore
    Member
    Posted 8 years ago #

    Is this by any chance a cPanel account? If you moved hosts, double check that your database credentials in wp-config.php are correct. It seems simple, but if your hosting account username was "user1" on your old account and is now "somethingnew" at your new host, your database name prefix has changed.

  11. mmarkham
    Member
    Posted 8 years ago #

    I'm moving from hosting at my house to hosting with GoDaddy. I did adjust the settings in my wp-config.php to reflect the new database host, user name, password, and database name.

  12. MichaelH
    Member
    Posted 8 years ago #

    Read here, http://wordpress.org/support/topic/59690?replies=7 that Go Daddy uses database HOST like mysql.secureserver23.com so make sure that's correct.

  13. mmarkham
    Member
    Posted 8 years ago #

    I'm sure I've got the hostname right, since when you click on the "install" link, it see's there's tables there and asks you to delete them before you install. The GoDaddy manager says I should be using mysql89.secureserver.net for the host name, and I am.

  14. MichaelH
    Member
    Posted 8 years ago #

    Your $table_prefix in wp-config.php is in fact correct?

    Can you use phpMyAdmin and make sure you have the option_name = siteurl set in the wp_options table.

    I think these lines of code are giving you that message--maybe someone can see something:

    $db_check = $wpdb->get_var("SELECT option_value FROM $wpdb->options WHERE option_name = 'siteurl'");
    if ( !$db_check && (!strstr($_SERVER['PHP_SELF'], 'install.php') && !defined('WP_INSTALLING')) ) {
    if ( strstr($_SERVER['PHP_SELF'], 'wp-admin') )
    $link = 'install.php';
    else
    $link = 'wp-admin/install.php';
    die(sprintf(__("It doesn't look like you've installed WP yet. Try running <a href='%s'>install.php</a>."), $link));

  15. mmarkham
    Member
    Posted 8 years ago #

    Hey all--

    I'm not sure what caused what caused my problems, but I managed to fix it this way. I installed WP as a fresh install, and then hand massaged my database backup to remove the table drops and creates and just left the table inserts. I then imported this partial backup into a clean wp install. This finally worked and I'm up and running. I think I'll start with a fresh backup of the running site on GoDaddy this morning. Thanks for the help!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags