WordPress.org

Ready to get started?Download WordPress

Forums

iThemes Security (formerly Better WP Security)
[resolved] Site login lost after using Backup Buddy to migrate to new site on same server (4 posts)

  1. tropicsnet
    Member
    Posted 1 year ago #

    Sorry but have to ask ... spent last 2 days trying to solve login problems with don't know how many different versions of the htaccess file and fixes I could find thru forum searches.

    What happened:
    Backed up old site ( which ran Better WP ) and restored to new site ( both on the same host server ) using BackupBuddy.

    New site works perfectly BUT I cant login. The new site login page has also lost the nice WordPress page formatting and looks like a 'text only' page. Can still login on the old website.

    When I try to login on the new site it boots me to a page not found page.

    New website is http://www.castaways.com.au and old site is http://www.castaways.co

    I thought it may have been something in the htaccess file so deleted it and tried again but no good so put htaccess back.

    Checked the wp-config file and new details all in place. Wnt as far as uploading new wp-config and inserting correct details but still didnt help.

    The wp-config was in the root prior to migration but ended up back in public_html. Have tried to place a copy in the root folder but doesnt help.

    The forgot password link on the new site login page also boots to a page not found.

    wp-admin diverts to page not found as does wp-login

    I did have Better WP Security installed on the old site and figure that may be doing something ... does anyone have any idea please?

    I have uploaded a fresh wp-config file with all the correct db info.
    I have changed all the old site links in the htaccess file to the new site links except for the

    "</Limit>
    <Limit PUT DELETE>
    order deny,allow
    deny from all
    </Limit>"

    section which still has the old db details for

    AuthName castaways.co
    AuthUserFile
    AuthGroupFilename

    If I change those to the new details then the site wont load at all.

    I deleted htaccess totally - new site wouldn't load and showed Internal Server Error/misconfiguration/unable to complete request.

    I deleted the Better WP Security content of the htaccess file - new site wouldn't load and showed Internal Server Error/misconfiguration/unable to complete request.

    Reloaded the htaccess file with Better WP Security back in and site loads but back to the old cant login problem.

    Tried all variations I think in the htaccess but cant get it working.

    Check the BWPS_lockouts table in the database and no records.

    So, questions are:

    I cant seem to de-activate the plugin by changing file name in WSFTP - permissions no doubt need to be changed but dont know what to. Tried to change to 644 but wouldn't allow me. Also tried to do same thru File Manager in Cpanel.

    Im guessing there is going to be something stupidly simple to fix this BUT it's been 2 long days and Im not any closer.

    Any thoughts would be hugely appreciated!

    Cheers

    Paul

    http://wordpress.org/extend/plugins/better-wp-security/

  2. tropicsnet
    Member
    Posted 1 year ago #

    All fixed. Problem was Better WP Security plugin.

  3. tropicsnet
    Member
    Posted 1 year ago #

    I went back to the old site, deactivated BWS and made a new backup.

    I then ftp'd into my new website, deleted all the file, deleted the database, recreated the database and then ran the BackupBuddy import and still didn't work.

    Checked the htaccess file on the new website and I had forgotten to delete that one ( duh ). Deleted it and logged in to my newly migrated website. Woohoo.

    First thing I did on the new website was download and reactive Better WP Security. All running smoothly. Hope this helps someone else ....

  4. CKissner - ProCntr
    Member
    Posted 1 year ago #

    Fought this all day myself and have a 2nd solution.

    1. I have my BWS set to basic settings, nothing too crazy.
    2. Keep BWS enabled and run your backups as normal. I do manual; haven't tried scheduled.
    3. Download the backup and importbuddy.php file. Upload them on your server (MAMP in my case.)
    4. When the ImportBuddy process throws an error, then go into your (now extracted) files and 1) go to /wp-content and create "plugins-x" (or whatever you want) and move the "better-wp-security" to the new folder which basically deactivates it and 2) change the permissions on your .htaccess file (in the main folder) to allow User to Write ( more if necessary) and 3) delete all the BWS code from that .htaccess file.
    5. Keep running ImportBuddy.
    6. Log into your site using Mysite.com/wp-admin (the standard link).
    7. Go to Settings > Permalinks and click save. You don't have to change the settings, just save it. (You'll find you need to do this for a a host of errors on WP, almost for sure when you can't access any page but the home page).
    8. Hope that saves time for others!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic