WordPress.org

Ready to get started?Download WordPress

Forums

Site keeps showing "This webpage has a redirect loop" (5 posts)

  1. Neil D
    Member
    Posted 1 year ago #

    Hi All,

    I'm new to the support forum. I have recently had major problem with one of my sites. It was a static site which I was trying to convert to WordPress.

    Therefore, I installed, WordPress into the root folder. I then removed all the static HTML, CSS and image files.

    The problem is, when I enter the domain name on Chrome browser, it says

    This webpage has a redirect loop
    The webpage at http://mysite.com/ has resulted in too many redirects. Clearing your cookies for this site or allowing third-party cookies may fix the problem. If not, it is possibly a server configuration issue and not a problem with your computer.

    I cleared the cookies so that's not the problem.

    And when I try logging to the admin area, it reads
    403 Forbidden
    Server configuration does not allow access to this page.

    I obviously did the static to WordPress installation wrong. What should I do?

  2. s_ha_dum
    Member
    Posted 1 year ago #

    part of that makes me think that your WordPress folders are not readable or not executable by the server.

    http://codex.wordpress.org/Hardening_WordPress#Changing_file_permissions

    You may also have a .htaccess issue. If the above lets you get into the admin section, at least try to reset your permalinks-- wp-admin->Settings->Permalinks.

  3. Neil D
    Member
    Posted 1 year ago #

    Hi s_ha_dum,

    Thanks for the reply. Can you tell me in laymen terms because I struggle on the technical areas.

    I can't access admin panel at all, because it says 403 forbidden.

    What are the list of things that I can try?

  4. pingulino
    Member
    Posted 1 year ago #

    Login to the server, with ssh if you have shell-access or otherwise ftp.
    Check the ownership & permissions, make sure that the user the webserver runs under has read-access to everything, write-access to wp-content.
    How you check that depends on how you login, make sure all files have at least 0644.

    If you're puzzled, return with info about how you can access the server.

  5. s_ha_dum
    Member
    Posted 1 year ago #

    You haven't given us your URL so I can't say for sure, but I am pretty sure that that is an Apache server error message, which implies a Linux or BSD server, aka. a *nix server. (You can run Apache on Windows but it seems to be pretty rare.) Every file and folder on a *nix system has a set of permissions that determine who gets to read, write, and execute a file. Folders, somewhat oddly, need to have execute permissions. I think you folders, at least some of them, do not have execute permissions. The link I provides tells you what the permissions should be, and pingulino told you how to get in to change them. Folders (directories) should be 755, and files should be 644. That will look something like drwxr-xr-x and -rw-r--r-- in FileZilla.

Topic Closed

This topic has been closed to new replies.

About this Topic