WordPress.org

Ready to get started?Download WordPress

Forums

Site just went bonkers (25 posts)

  1. bambam4479
    Member
    Posted 9 years ago #

    try restarting mysql and apache. This has happened to me before and I had to do a whole system reboot to fix.

  2. kcomphlint
    Member
    Posted 9 years ago #

    this server isn't sitting under my desk. it is hosted elsewhere.

  3. Ask your host if they changed anything.

  4. kcomphlint
    Member
    Posted 9 years ago #

    Well, the odd thing is that my refer and shortstat tables are in the same database, and they are both working fine.

  5. TechGnome
    Moderator
    Posted 9 years ago #

    Did _you_ change anything recently? Add any new plugins or anything? The SQL is all screwed up. In looking at the errors generated, it looks like the code that creates the SQL may have been altered. PostIDs that are supposed to be part of the queries are not there.
    Tg

  6. kcomphlint
    Member
    Posted 9 years ago #

    The only thing I changed was this morning, I added htaccess to my refer directory. I didn't touch anything in my WordPress files. I made a post last night about the Firefox NYTimes ad, and it seemed to be working fine (checked the site after the post, and it was there).

  7. kcomphlint
    Member
    Posted 9 years ago #

    I looked in my database, and noticed that all of my posts had a category setting of "0". Shouldn't they have the ID of the category as that value? At least "1" if nothing higher?

  8. Ryan Duff
    Member
    Posted 9 years ago #

    no the category gets set in the post2cat table. each post id should have a category id associated with it in that table.

  9. trevorturk
    Member
    Posted 9 years ago #

    i'm having a problem that might be related: when i use the nightlies or whatever, my blog url is getting changed from /wordpress to /cgi-system. i'm on dreamhost, which runs cgi-php as the default, and i've tried a bunch of stuff. it seems that when i try to log in, my blog url gets changed. any ideas?

  10. kcomphlint
    Member
    Posted 9 years ago #

    gotcha...all those values are intact.
    I can see the post that I made last night, so whatever happened had to have been around then.
    When I go to my WP admin page, all the menu items across the top say "Array", except for View Site and Logout.

  11. TechGnome
    Moderator
    Posted 9 years ago #

    kcomphlint - try undoing you the .htaccess you did and see if the problem goes away. If so, then there might be aconflict going on in there that's causing the settings to be cleared out.
    Tg

  12. trevorturk
    Member
    Posted 9 years ago #

    My problem has been solved, thanks to BigJibby. You need to add this line to the top of your wp-config file:
    $_SERVER['SCRIPT_NAME'] = $_SERVER['SCRIPT_URL'];
    Put that right above where it says:
    // ** MySQL settings ** //
    And you're all set, I guess.
    Read more about it?
    https://panel.dreamhost.com/kbase/?area=2933

  13. trevorturk
    Member
    Posted 9 years ago #

    I guess you can also choose not to run php-cgi. In Dreamhost, you do this by going to Domains -> Web -> Edit.

  14. kcomphlint
    Member
    Posted 9 years ago #

    Tried trevorturk's suggestion, but that didn't work either.

  15. trevorturk
    Member
    Posted 9 years ago #

    I think there is a problem with the 12/16 nightly, if that's what you're using

  16. kcomphlint
    Member
    Posted 9 years ago #

    I am using WP1.2....i don't even think it is 1.2.1, just plain old 1.2.

  17. Update to WP v1.2.2, and make sure to run upgrade.php.

  18. kcomphlint
    Member
    Posted 9 years ago #

    just a note, my WP homepage is now at index-2.php if you are wanting to view the database errors.

  19. kcomphlint
    Member
    Posted 9 years ago #

    I tried updating, and when i ran the upgrade, all kinds of SQL errors were thrown.

  20. Trevor, I'm on DreamHost and have never had to do what you needed to, nor have I had any problems running PHP as CGI.
    Kcomphlint, have you asked your host if they changed anything with MySQL yet?

  21. kcomphlint
    Member
    Posted 9 years ago #

    Well, I had thought of that, but my refer AND shortstat scripts pull from tables in the same database, and they are having no problems getting data. I would think that if something in the MySQL changed, those would be affected as well.

  22. kcomphlint
    Member
    Posted 9 years ago #

    According to my Host, PHP was upgraded last night.

  23. kcomphlint
    Member
    Posted 9 years ago #

    Problem solved. My host upgraded PHP last night to ver.4.3.10, and they were running Zend Optimizer. The new version of PHP conflicted with the version of Zend they were running, so they upgraded it too. All happy now.

  24. moshu
    Member
    Posted 9 years ago #

    Your host could come here to learn about it :)
    http://wordpress.org/support/3/18678

  25. kcomphlint
    Member
    Posted 9 years ago #

    Thanks for the link. I would have never thought that the PHP upgrade would screw things up like that.
    Then again, I have no idea what Zend Optimizer is or does.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.