WordPress.org

Ready to get started?Download WordPress

Forums

Site in sub folder on hosting, database problem (4 posts)

  1. chachiarcola
    Member
    Posted 2 years ago #

    Hi, I have searched the forums and google, and am either dense or am just not seeing the correct way to go about fixing a problem I created for myself.

    I have a WordPress install running and for whatever reason listed the WordPress url as the main domain name/folder. I don't think it is important for me to give actual links to the site, but can if needed.

    Essentially, the General settings page in the admin section reads something similar to this:

    WordPress address (URL): http://mymaindomain.com/hosted-site
    Site address (URL): http://hosted-site.com

    What I want:

    WordPress address (URL): http://hosted-site.com
    Site address (URL): http://hosted-site.com

    Because of whatever I did when I installed the site, and then created the posts, when the site tries to load the second page of posts, or an individual page/post from the menu, it goes to the WordPress url version of the permalink stored in the database.

    Is there a somewhat simple fix? Or an even somewhat not simple fix? I have backups of the database, and have tried changing the url in general settings, and saving, but it reverts to the screwed up url. I have never done any mysql back-end edits, and would be willing to try if that is the only way.

    I would just start from scratch, but have something like 300 posts that are all tagged and such, and don't really want to go that route if I can help it.

    Whatever help or direction would be appreciated. I can also update details if needed.
    Thank you!

  2. Peter Shilling
    Member
    Posted 2 years ago #

    Sounds like when you installed wordpress you chose to put it in a folder.

    You could try this... .

    Move all of the files out of the folder and into the root directory of your setup. You also need to tell wordpress about this so before you do it, go into the admin and setup both addresses so they don't have the folder. Save it and the do the move via FTP

    WordPress address (URL): http://mymaindomain.com/
    Site address (URL): http://hosted-site.com

    Goodluck!

    PS

  3. chachiarcola
    Member
    Posted 2 years ago #

    Hi Peter,
    Thanks for the help, but I can't do what you said.

    I have my own wordpress website, with its own install/database set up in the root folder of my server, and a friend's portfolio styled wordpress website installed in the subfolder with its own install/database. Sorry if I wasn't clear.

    I didn't use actual urls, but my site uses the "mymaindomain" URL, with my friend's site using the "hosted-site" URL. I have other WordPress installs set up the same way, inside a sub folder with their own install/database and they work fine. This one seems to be screwed up because I guess I used the sub folder in the WordPress address when I first set it up. Don't ask me why, I am not sure myself why I did it.

    I have tried setting the addresses in admin general settings for "hosted-site" so that both the WordPress address URL and SIte address URL both point to the "hosted-site" URL, but after I save the settings, it reverts back to the previous pair of URLs

    So to be clear, this is how it is set up now:

    WordPress address (URL): http://mymaindomain.com/hosted-site
    Site address (URL): http://hosted-site.com

    What I want:

    WordPress address (URL): http://hosted-site.com
    Site address (URL): http://hosted-site.com

    I have other installs that work fine set up like this, and they are in subfolders at the same hierarchy level to the root of my hosting, with their own databases:

    WordPress address (URL): http://other-hosted-site.com
    Site address (URL): http://other-hosted-site.com

    But when I try to change the WordPress URL in admin General settings, it reverts back to the way it was after I save.

    I am worried that the only way to change it would be to edit the mysql database, which I have never done, and need help doing so. I should also mention that there are something like 300 posts on the "hosted-site" install, and they have uploaded/embedded images with their links pointed to "mymaindomain.com/hosted-site" A big scrambled mess... The posts show up if you know their permalink URL, but navigating to them is broken when using the menus.

    I would like to be able to fix the WordPress address URL problem, and not break all those links in doing so. Is there some sort of how-to somewhere, or a plugin of some sort perhaps?

    Thanks again.

  4. steelteal
    Member
    Posted 1 year ago #

    I have the same issue as chachiarcola...

    I redirected a "godaddydomain.org" to "mydomain.com/_clients/godaddydomain", which is where I have the new wordpress site setup and running nicely.

    The problem is, I can't change the permalinks to pretty links, otherwise I get 404 errors, AND the URL shows as the folder structure "mydomain.com/_clients/godaddydomain

    Is this just an .htaccess issue?

    Thanks!

Topic Closed

This topic has been closed to new replies.

About this Topic