WordPress.org

Ready to get started?Download WordPress

Forums

Site hacked by Markov (6 posts)

  1. aschobey
    Member
    Posted 10 months ago #

    Site was hacked and now rss (http://www.arteffects.com/feed/) not working.
    Do not know where or how to fix this. Can anyone help?

    Get error:
    XML Parsing Error: XML declaration not well-formed
    Location: http://www.arteffects.com/feed/
    Line Number 1, Column 38:<?xml version="1.0" encoding="charset iso-8859-1"?>
    -------------------------------------^

  2. Diogo
    Member
    Posted 10 months ago #

    Being hacked is never fun.

    Are you using the latest version of WP? Do you use any plugins to generate your feed?

  3. Diogo
    Member
    Posted 10 months ago #

    The problem seems to be with the encoding value. Did you set it manually? I'm not sure if the 'charset' should be there. Here's how a valid encoding declaration looks like:

    <?xml version="1.0" encoding="UTF-8"?>

  4. aschobey
    Member
    Posted 10 months ago #

    Yes, using latest WP, no plugins for feed.

    I've not set anything other than theme CSS manually. I'm not a coder an my guy is out of the country.

    The problem with the feed just appeared overnight after being hacked.

    I have no idea where the file is that would contain the involved value either. Where should I look?

  5. esmi
    Forum Moderator
    Posted 10 months ago #

  6. aschobey
    Member
    Posted 10 months ago #

    Found the location for setting encoding to UTF-8 and it is now working. Thank you for the help folks!

Reply

You must log in to post.

About this Topic

Tags