WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Site does not load resources from windows machine or mobile devices (3 posts)

  1. joemoe1984
    Member
    Posted 1 year ago #

    Ok so I have MAMP installed on my MAC and I have it running. I have a custom theme using WordPress 3.5.1 and its working so far. No problems.

    I then thought I would try it out on my mobile device so load up 192.168.1.123 (this is my local ip for my mac) and the site loads but without any resources. No CSS, No Javascript and No Images.

    This was weird so I tried it on my Windows machine and same thing. Using the Chrome Debug tools Nothing is loading. I get Failed to load Resource for everything under Resources.

    I checked the path under Windows Chrome and this what it tried to load for the css file

    http://localhost/website_name/wp-content/themes/website_name/style.css

    I checked my MAC Chrome and its the same.

    Does it have to do with the localhost part? The resources tend to be loading from localhost on other machines but it probably should be loading from 192.168.1.123. I just don't know how to fix this.

  2. joemoe1984
    Member
    Posted 1 year ago #

    Also I have been trying to Google my answer however there are a lot of sites down right now....Stackexchange, OSXDaily and more...

  3. joemoe1984
    Member
    Posted 1 year ago #

    Ok so stackexchange is up now and I also Just figured out how to fix the problem. I figure I will share with you for anyone who is having the same issue.

    I went to the wordpress admin page and went to Settings > General. From there I replaced localhost with my local ip in both the site address and wordpress address.

    This seemed to have fixed it.

Topic Closed

This topic has been closed to new replies.

About this Topic