WordPress.org

Ready to get started?Download WordPress

Forums

Site Becomes A Mess Without The Slash On The End (6 posts)

  1. pbcunningham
    Member
    Posted 6 years ago #

    Hi,

    First time post here so please be gentle!!

    I have an issue which I am attempting to resolve, but have yet to be able to do so, therefore I am hoping I may be able to locate the answer here.

    If I go to a category, post etc (basically any area of the site) without a slash on the end the appearance of the site becomes all of a mess.

    The header does not work correctly, the background does not load, the text changes colour etc.

    If you go to the following link then you will see how it should look :

    http://www.aquaristsonline.com/blog/

    And then if you go to the next link which is exactly the same without the slash you will see the issue I am having :

    http://www.aquaristsonline.com/blog

    I have been through all of the plugins and deactivated them all and still I get the same issue. I then went through and activated them one at a time, checking inbetween yet still the same issue.

    I have checked and rebuilt the permalinks and still get the same. The permalinks are set to custom and are as follows :

    /blog/%category%/%postname%/

    I have checked and even removed the .htaccess file but still the same.

    I am really pulling my hair out with this one and am really stuck. I have contacted the support department of the people who host this blog and they could not work it out. All the other peoples sites they host which are on the same version are all ok so it is something individual to my site.

    I would really appreciate any help you can offer on this one and hope that I have provided enough information to assist in the diagnosis.

    Thanks in advance

    Peter Cunningham

  2. anatman
    Member
    Posted 6 years ago #

    Maybe a relative URL in a CSS rule? I suggest you use Firefox, install the web developer toolbar extension, and check for that. Or, just check the CSS for relative URLs.

  3. pbcunningham
    Member
    Posted 6 years ago #

    Hi, thanks for the reply.

    I installed the developer toolbar and it all looks ok - everything is relative.

    I have managed to force a trailing slash onto all pages in the .htaccess and all pages now work with the exception of the home page. Even though there is now a forced trailing slash on the home page the CSS still does not display correctly.

    Peter

  4. whooami
    Member
    Posted 6 years ago #

    you dont have a forward slash after either of your settings on the options -> general page, do you?

  5. pbcunningham
    Member
    Posted 6 years ago #

    Hi,

    I have just checked and no I don't.

    What I have just tested though is strange.

    If I go to http://www.aquaristsonline.com/ it does not work

    If I go to http://www.aquaristsonline.com/index.php it does not work

    However if I go to http://www.aquaristsonline.com/index.php/ it does work.

    Driving me mad this one.

    Thanks

    Peter

  6. pbcunningham
    Member
    Posted 6 years ago #

    I tried to force a trailing slash onto the site by using the .htaccess file. Whilst it seemed to resolve the display issues it had a side effect.

    With the trailing slash forced via the .htaccess the display was now ok but if you click on a link to read a post it would not go to the post.

    Below is what my .htaccess file looks like - forgive me I know absolutely nothing about these files. Everything that is in there has been put in by wordpress.

    AddType application/x-httpd-Miva cp
    Action application/x-httpd-Miva /cgi-bin/tHg
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    # These Rules redirect all feed Traffic to FeedBurner
    RewriteBase /
    RewriteCond %{QUERY_STRING} ^feed=(feed|rdf|rss|rss2|atom)$
    RewriteRule ^(.*)$ http://feeds.feedburner.com/AquaristsOnline [R,L]
    RewriteRule ^(feed|rdf|rss|rss2|atom)/?(feed|rdf|rss|rss2|atom)?/?$ http://feeds.feedburner.com/AquaristsOnline [R,L]
    RewriteRule ^wp-(feed|rdf|rss|rss2|atom).php http://feeds.feedburner.com/AquaristsOnline [R,L]
    # These are the standard WordPress Rules
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php/ [L]
    </IfModule>
    # END WordPress

    Thanks in advance for any advice anyone can offer.

    Peter

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.