WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Site and wp-admin become inaccessible after publishing (11 posts)

  1. shazapp
    Member
    Posted 7 years ago #

    I've been using WordPress for the last year had haven't run into any problems I couldn't fix until yesterday.

    After attempting to publish a story to my site, I became unable to access any of the WordPress content on my site. All of my non-WP content is accessible and works just fine.

    This began happening before installing WP 2.2.

    I did a complete reninstall to upgrade to WP 2.2 and everything was fine until I attempted to publish an article. Then, once again, I was unable to access any WP content, including Dashboard, on the site.

    When I access any WP content, I am not getting any PHP errors or any other errors of any kind. That's what's so frustrating. The site just displays a blank page after a long time.

    I'm running WP 2.2
    on PHP v4.4.4 and
    MySQL v4.1.21-standard

    Any ideas on what's happening?

  2. Dgold
    Member
    Posted 7 years ago #

    I'm getting blank pages after clicking various tasks in the Admin since going to 2.2.

    After I publish a post, it goes to a blank page. After I edit a Post, or a Comment, it goes to a blank page. When I click "Login" it goes to a blank page if it does not have the www in the address. So strange.

    I don't know if this has something to do with my blog address (haven't changed it in years), or with my htaccess, or with my host, or what. I don't even know where to look right now. Hoping this thread gives an answer & going off to search/read more posts about this since 2.2 came out.

  3. whooami
    Member
    Posted 7 years ago #

    try disabling mod_security - it seems to be causing lots of problems

  4. shazapp
    Member
    Posted 7 years ago #

    I can't access wp-admin or the dashboard to change anything. I have no plug-ins activated.

  5. Dgold
    Member
    Posted 7 years ago #

    @shazz, did u try it with the www and without? Also try a couple different addresses in your wp-admin, and hard-refresh it. Hopefully it will pop up! I saw you said you reinstalled (make sure the files all uploaded for the admin folder). And you have No plugins. Good luck & try it again.

    ---

    whooami wrote "try disabling mod_security - it seems to be causing lots of problems"

    Since I don't know very much about mod_security (just been reading up on it) -- should I disable it for the entire wp-admin folder? That folder doesn't have an htaccess, I might make one and put
    SecFilterEngine Off
    in it.
    Or should I be trying to figure out how to disable mod_security for just the php files that are having problems (edit and edit-comments, and maybe index/dashboard)?

  6. whooami
    Member
    Posted 7 years ago #

    I would go the easy route, and disable it for the whole directory at first -- to see if that IS the problem. If it doesn't fix it, then at least you haven't spent more time figuring out the specific files and whatnot.

  7. shazapp
    Member
    Posted 7 years ago #

    Well, I woke up this morning and now it's working fine. I'm assuming this was a host-related issue and not a WP issue...which is a good thing. :)

    Thanks for the attempts at helping, everyone.

    And, just to answer some of the questions. It was not working with www or without and I couldn't access any WP related files or directories. Just the non-WP related ones. Hard-refreshs didn't make a difference.

    In any case, it's working now. Thanks. I'll leave this as unresolved for Dgold's problem.

  8. Dgold
    Member
    Posted 7 years ago #

    Thanks for helping whooami (and shaz for leaving it open).

    This is my first time writing an htaccess like this

    I made an .htaccess file with ONLY the one line
    SecFilterEngine Off

    That is the only thing in the text file. Is that correct?

    It didn't fix the problem. Yet.

  9. whooami
    Member
    Posted 7 years ago #

    yeah that will work -- did you get any server error, by chance? If not your host is using it

    This:

    <IfModule mod_security.c>
    SecFilterEngine Off
    </IfModule>

    lets Apache know that it shouldn't do anything if mod_security isnt installed, and prevents server errors where using this:

    SecFilterEngine Off

    without wrapping it would cause an error.

    Does that make sense?

    Thats just a tidbit of knowledge, btw, if you didnt get a big white page with a server error after using the single line solution, you dont have to worry.

  10. Dgold
    Member
    Posted 7 years ago #

    trying... trying... trying to wrap my brain around this.

    I used JUST

    SecFilterEngine Off
    without wrapping it

    and I still got a blank page, as before. It did not fix the problem, and it did not give a new error message. What's that tell us?

    If I'm reading your previous post right: the fact that I did not get a server error, but did still get a blank page, means my host IS using mod_security. Ok, so what does that tell us? Can I turn it off for wp-admin? Or that was turning it off?

  11. Dgold
    Member
    Posted 7 years ago #

    I didn't have to disable mod security after-all, or, well, that turned out not to be the problem & I got mud on my face, a bit embarrased cuz it was something I did, that I should have figured out earlier. Problem was a blank space at the end of a plugin file -- a plugin having nothing to do with Post or Edit Comments or Admin, but nevertheless it was the problem I believe.

    Thanks everyone for the help

    whooami thanks for looking into my questions today and giving advice that ultimately led back to the solution.

    RESOLVED

Topic Closed

This topic has been closed to new replies.

About this Topic