WordPress.org

Ready to get started?Download WordPress

Forums

SyntaxHighlighter Evolved
SintaxHighlighter Evolved incompatible with Latex for WordPress plugin (2 posts)

  1. Luca
    Member
    Posted 1 year ago #

    Hi,
    on my WordPress website is use both the Latex for WordPress plugin and the SyntaxHighlighter Evolved plugin.
    (I think it is pretty common that who writes about numerical simulations wants both mathematical formula and code displayed on its website).

    I had no trouble for a long time till I needed to post the following bash code

    [bash]PS1="\[\e[1;31m\]name\[\e[0m\]@\h:\w\$ "[/bash]

    When having both SyntaxHighlighter and the Latex plugins enabled, this code is not displayed correctly. However if I disable the Latex plugin it is correctly rendered.

    What I think is causing the issue is that the latex plugin (MathJax) thinks that \[ and \] is latex code.

    Is there a way to avoid code to be highlighted by SyntaxHighlighter to be parsed also by other plugins?
    (I think this is a general issues, not only of incompatibility with Mathjax.. e.g. think that I want to write the Python code:

    x = [aname] and a name is some shortcode used by other plugins.

    If you could make the code in between SintaxHighlighter short codes isolated from the rest, that should solve the compatibility issues.

    Apart from disabling the Latex plugin how can I fix the issue on my website???

    Cheers,
    Luca

    http://wordpress.org/extend/plugins/syntaxhighlighter/

  2. Luca
    Member
    Posted 1 year ago #

    For those who have the same issue: the MathJax Latex plugin works fine with SyntaxHighlighter Evolved, although it has much less functionalities.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic