WordPress.org

Ready to get started?Download WordPress

Forums

Single Post Comments Feed is empty and gives a 404 error (3 posts)

  1. bluantinoo
    Member
    Posted 2 years ago #

    Hi all,
    I have a strange problem and I cannot figure out how to solve it.
    I google it for some times but never found out a topic or an article speaking about a solution on this.

    Basicly I have a huge number of 404 errors (found on google webmaster tool) that are generated on every single post comments feed url.

    I mean this: http://www.mysite.com/article-title/feed/

    If I visit that url, it gives me an empty rss file (EVEN IF THERE ARE COMMENTS)

    You can have a look, this is the link to a single content on my site:
    http://www.benessere4u.it/la-musica-che-ci-aiuta-ad-ascoltarci/

    this is the link to the comments feed of that post
    http://www.benessere4u.it/la-musica-che-ci-aiuta-ad-ascoltarci/feed/

    as you see, even if there are 3 comments, the rss comments is empty.
    This (don't know why) generates a 404

    Naturally this is happening even on posts WITHOUT comments...

    I'm really stuck on this. Any idea?

  2. esmi
    Forum Moderator
    Posted 2 years ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the Twenty Eleven theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    - re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress.

  3. thinkero
    Member
    Posted 1 year ago #

    Hi bluantinoo,
    did you found any solution to your feed errors?
    I'm receiving the same 404 errors in Webmaster Tools

Topic Closed

This topic has been closed to new replies.

About this Topic